Nautilus Unable to Remove Network Links

I had 2 SSH links in Other Locations that have worked for years.
I have added SSH to my servers and removed password login.
I have added the SSH keys to SSH_Agent and have ssh.conf file to name the Hosts.
I can login no issue to all my servers and have no issue .

But now my access via Nautilus is blocked with the current connections and i cannot remove them.
Please can you tell me how to fix or remove them.
I can add new with ssh://hostname but it only gives me a few file not the root of the server ??

It is really frustrating that i can do nothing with them

How exactly did you add them?

now my access via Nautilus is blocked

What does this mean? What is “blocked”? What happens if you try to open them? Does it ask for password?

Maybe you’ve once set the password to be remembered forever and you need to remove the password from the keyring. In that case, this application may be of help: Flathub—An app store and build service for Linux

Are those maybe not stored locally but added via DNS-SD on the host? If so, they should show up in avahi-browse -a -r as well.

I can add new with ssh://hostname but it only gives me a few file not the root of the server ??

I think if you just access ssh://hostname you get the home directory of the user you are connecting to. If you want a different path, you have to specify ssh://hostname/path/. Can’t test this right now though.

  1. I am not 100% sure i think SSH with password or ftp

  2. I seem to remember via ssh with a password

Nope the both show same popup

I have tried using the tool cheers it has not helped.
There is no way to remove them really frustrating

What if you install it first? Depending on how your distro splits packages, you might still have the avahi libraries installed for gvfs, but not the commandline tools.

Anyway, Sebastian is probably right. For network places which are not mounted to appear in Other Locations, it must be autodiscovery.

Please could you break that down a litlle simplier for a Linux noob.
I have 25 years etched into my old Wndows brain.
I recently moved to Fedora a few months ago and trying my best to read and understand.
But some stuff is a little abve my current knowledge base:)

In simpler terms, the links listed in Other Locations have not been “added”. They are automatically detected feom your local network.

Maybe the server is broadcasting wrong information, or the autodiscovery from this side is misunderstanding it.

The autodiscovery service is provided by software package called avahi. In order to gather more clues about what avahi knows about the server, it would be useful if you manage to install the avahi-browse utility program. You got the “command not found” error because it’s not installed.

I’m not 100% sure, but this utility program is probably included in the avahi-tools package. So, can yoou install it with the following command and then try again to provide the information Sebastian asked for?

sudo dnf install avahi-tools

These 2 links have worked for a long time.
But I added ssh keys now, before it was ssh with password.
Now it’s ssh keys and they stopped working.
But I cannot edit or remove them

You cannot edit nor remove because it’s all automatic detection.

While you were writing your last reply, I’ve added a second message above, with how to get more information about what’s going on, which you may have missed. Please see above.

Hi yes I did read but I find it impossible to beli that the day I add ssh login to two separate servers on the same day.

Both these 2 links in nautilus fail, so I has to be the latter.

So my nose tells me it’s my laptop but how do I investigate that.

I know I could delete the ssh keys but kind of defeats the object.

I am amazed there is no way in logs to see the exact issue or terminal to stop / delete these or edit.

The key password is ok if you can remember your 40 connections the descriptions are all blank

That’s what I wrote about. Please read the instructions to install the avahi-browse above.

This post specifically Nautilus Unable to Remove Network Links - #14 by antoniof

Apologies I didn’t see that post