Nautilus Nextcloud icons are a problem

I’ll briefly explain my case: I am using the nextcloud client on Fedora 38 gnome.
I have several local folders (most system folders: desktop, documents, pictures…) individually synchronized with nextcloud, rather than a single nextcloud folder.
This makes all of those folders appear in nautilus’ sidebar, but In my case this is completely useless and bloats the sidebar, since they represent system folders which are already there.

  1. Is there a way to disable this function? Any .config file I should edit? I have searched online with no luck so far.
  2. There should be an official option to show/hide those folders, or at least a dropdown menu.

Many thanks for any solution!

I will try to help, but I am not an expert ! just concerned about nextcloud integration as a simple user…
So you may have nextcloud-desktop package installed, correct ? and you are talking about links in the sidebar with the nextcloud icon ?

Did you check content of /usr/share/cloud-providers folder ? What do you have here ?

Thank you! So, in the directory you mention there’s one file: com.nextcloudgmbh.Nextcloud.ini .
This is the content of the file:

[Cloud Providers]

Ok, just like me (I am on Debian).
So, the following is just a hack : what if if you move that file to your home dir ? (to keep a copy). On my system, the nextcloud links disappear from nautilus sidebar. This is what you are asking for.

As far as I know, there is no Gnome parameter available to make that choice (which would be nice).
And keep in mind that when nextcloud-desktop will upagrade, the file will be back…

I hope this helps.

Well, it works instantly!
Thank you a lot, this really solves the problem for now!
I also really hope Gnome implements an easy option though. Otherwise it’s more of a bug than a feature.

This worked for me originally, but since a couple days it has come back and doesn’t seem to be influenced by the /usr/share/cloud-providers being empty…
Is there anywhere else they are controlled from?

remove or comment out the cloud provider entries in the desktop file /usr/share/applications/com.nextcloud.desktopclient.nextcloud.desktop

1 Like

This sounds like a bug indeed. If a folder is already in the sidebar, it should not be added a second time.

I’ve filed it on GitLab not to forget to fix as part of the upcoming sidebar code changes. libcloudproviders locations may duplicate folders already present in the sidebar (#3208) · Issues · GNOME / Files · GitLab

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.