Is this the place to post UX feedback?

I’ve never used Linux before and didn’t really plan to, but Windows 11 drive me away so here I am. Much I was very pleasantly surprised by, but there were some pain points which I’ve documented during the past couple of months:

  • First of all, just as a personal curiosity, I’m wonder who looked at who here (remember “Redmond, start your photo copiers”), because I must say that the Gnome desktop experience is extremely MacOS like… the virtual desktops, the exposé feature, the swiping gestures, the dock… but it’s nice and super smooth!
  • Now, one problem is that while Windows/MacOS has a centralized problem reporting feature (which granted, only bots read, if even that), Linux with it’s different distros, desktops and drivers don’t so a newbie user like me is quite lost as to how to report an issue, or even where that issue might originate from.
  • My distro (Nobara) had a codec installation bundle which completed but an error message with a reinstall popup disappeared after a while. I think this was resolved, but Youtube videos in Firefox stuttered for quite a while.
  • Popup after reboot that nvidia drivers require internet connection… not what I expected from Linux, but perhaps it’s to be expected from Nvidia.
  • Overall themeing in Fedora/Gnome is very confusing. There’s very little in Settings, a bit more in Tweaks, and if you want even more you have to use Extensions. Changing the accent/selection color seems to require an extension, and the “User Theme” extension which had a button for “user accent color”, I still couldn’t figure out because I didn’t find where to change the color in the end… there even was an extension for just accent colors but it didn’t work either. There’s even a “Nobara Layout” app which had an accent color selection but that one didn’t work either. EDIT: The only app on the entire system which cared about the changed accent color, even after a restart, is the Gnome Settings app. Not even the toolbar at the top of the screen cares that I changed it.
  • Software app has Darktable listed twice. When I install one of them, it doesn’t show both as installed. So what’s the difference? EDIT: Ok, so apparently one is from Fedora and one is from the developers themselves? Many apps are the same, but terrible first use UX.
  • Thunderbird is also listed twice, when I searched for it… two different icons too… only by clicking on it can you spot differences… one is a flatpak, whatever that is, and one says the distro name, but the distro specific one was 3 months old, and the flatpak was 5 days old (according to the distro maintainer, that’s pulled directly from Fedora, so Fedora hasn’t updated Thunderbird for 3 months)? EDIT: This is apparently pretty common as well, which is very alien coming from a Microsoft/Apple environment where you get updates immediately you hear about them.
  • Also, while writing this, Supernova was just released, and 24 hours later, neither app version has that update… three days later, still nothing… so now I went to their Mastodon and they say they are maintaining it on Flathub themselves… so I use the Gnome desktop search for search for it, and I get a hit in the Software app… says it needs installation… so I click on that… and I get an error message that it can’t be installed “without an icon”.
  • Dragging an icon in the dock, is weird… when I want to start to drag, only a popup window appear and the cursor appears to freeze if you try to move it horizontally… only after you release the touchpad does the icon attach itself to the cursor, and you can drag and click to release it where you want (this seems like an intermittent Microsoft Surface Studio issue, despite me using a distro with all available kernel patches pre-installed).
  • Keyboard shortcuts aren’t listed in the drop down menus for applications? I don’t know what the shortcut for quit is on linux and not sure now how to find that out…
  • I don’t know how to reduce the two finger scrolling speed. It’s very, very fast (this was a Firefox issue… I had to look up a Stackexchange answer on how to slow it down in about:config, which apparently also slows down mousewheel scroll which could be an issue if I ever wanted to use both).
  • More newbie questions popping up… I have a Microsoft Surface Studio Laptop running at 2400x1600 120hz but the first game I tried to launch in Steam (natively, I haven’t installed Proton or what it’s called) yet the maximum and default resolution it chose was 1599x1066 120hz…
  • The test mouse & touchpad app only tests for single click and double click, not right click! (also, the scrolling indicator looks as if it’s part of the graphics so I missed that it was an instruction)
  • There’s a region format in the settings, but even if you set it to a European country, you have to go into the date & time separately to set the 24h clock that’s always on the screen.
  • The question mark to get help in the file manager for remote server is very nice, but it takes up to a minute to connect to a Windows machine on the network, and almost the same length of time to switch folders… I have to wonder if this is normal these days, because I get a notification that the server is “ready” when it’s finished… but still very weird.
  • However, the above only worked once. I get “Unable to Access Location” “Failed to retrieve share list from server” “Access Denied” and “Permission Denied” when I click on the previous connected location in the Files menu for “Other Locations”. Yesterday I could connect to a Windows share, today I can’t. EDIT: Searching for this issue, I find threads about it going back to 2013. I must admit, that this hasn’t been fixed, whatever the technical reasons are, is really problematic. Btw, I can ping the exact same address just fine.
  • My distro apparently has something called Samba4k in the Software App. However, the UX is quite convoluted, and seems to rely one some KDE encryption wallet which doesn’t work well (or at all) on Gnome. However, unlike the Gnome Files app, this one was able to establish a connection to my Windows share again… which then opened in the Files app. First rather big oof.
  • Shortly after the above, I did discover the Connections app, and was very surprised to see that I was able to connect to that same computer via remote desktop. That’s impressive and surprisingly smooth considering the above experience.
  • The Files app doesn’t allow you to click on the address field to paste a path (like you can in Windows). You have to know about the ctrl-l shortcut to do that, but how do you find that out if you don’t know about it (someone told me in a chat)?
  • When a Libre Office toolbar icon overflows into the “>>” menu (I have 2x display scaling on) you can no longer open submenus under those icons. not sure if this is a Libre Office issue or a Gnome issue…
  • In the settings I can see that my printer has been automatically added, which is nice. However, what is not nice is that in Thunderbird, neither the custom print dialog or the system dialog can see it. (Also, some “Linux Experience” Youtube channel with 281k subscribers was all braggy about Linux never needing drivers for printers… turns out he was full of crap. Surprisingly, Canon released Linux drivers back in 2013 which still worked, although they required running a shell script to install, which maybe not everyone will be able to on their first attempt. Oh, and now I have two printers in the dialog and I don’t know how to remove the non-working one.
  • Not sure if it is the Microsoft surface studio laptop touchpad, but dragging and dropping with it is very difficult. quite often the cursor gets absolutely stuck in the middle of a drag operation!
  • The progress indicator in the file manager is super weird, and even took me a while to find. it creates the icon for the file immediately, but uses a blank one for it (and says 0 bytes in the status bar)… then nothing seemingly happens… unless you spot the tiny little clock in the toolbar, which is a very weird place for it. then you can click on it and you get the proper progress dialog.
  • General opinion: modern Linux can apparently also pop up any dialog or application window on top of what you’re currently doing so if you’re, for example, writing this text and pressing enter for new paragraphs, you accidentally close something that just popped into view and you don’t know what that was. Gone are the days of BeOS or the first OS X release when that was explicitly forbidden… this is a huge pet peeve of mine!
  • Interestingly, despite the above being the first thing happening to me, a few days later the experience seems to be that Linux is overly careful with stealing focus in many other ways. For example, clicking a link in a Mastodon app in one virtual desktop, only gave me a notification that the page was ready in Firefox, and I had to manually scroll over to the virtual desktop containing it.
  • Continuing on the above, a third variation on the notification/focus behavior in Linux was the someone posted a message in a Discord server I was monitoring. After seeing the notification, I open the notifications drop down menu and click on the notification. Nothing seemingly happens. However, when I manually switch to the virtual desktop Discord is in, I see that it has changed servers to show the message from the notification. It feels weird that apps can steal focus (though I haven’t encountered it much after day 1), yet when I expect that focus would be explicitly switched after my interaction, Linux just don’t, and makes me switch it manually.
  • I downloaded an app which wasn’t available in the Software app, and it only needed to be unzipped to run (Unreal Engine). However, I wasn’t able to add the app icon to the dock as a shortcut (no dragging and no right-click shortcut menu, and no dragging it into the “show apps” collection either).
  • Unreal Engine isn’t officially supported in anything but Ubuntu (the Linux desktop fragmentation is the largest hurdle for general adoption, but I guess everyone knows that), but it sort of behaved fine. It refuses to work with the virtual desktops and sometimes performance completely tanks if you even open a second window. Oh, at one point I discovered that the delete key didn’t work but what actually had happened was that the Files app in the background was deleting the selected file instead… (luckily the Gnome desktop had a traschcan I could fish it out of). EDIT: It happened a second time, I wasn’t able to type in Unreal, but the keyboard input had ended up in the search field in the address bar in Files app instead.
  • I also downloaded an app which had a flatpack link. It downloaded to my Downloads folder and then opened in the Software app allowing the install. Once the install was ready, the app (a Mastodon client) used Firefox to get authorization to log in and I got a nice system default notification once it was done. Very slick experience!
  • Maybe the fault of my Microsoft Surface Studio Laptop, but dragging operations work like 20% of the time. It’s frankly quite abyssal and I avoid it as much as I can. Nobara apparently has some Surface support built in (like orientation and touch screen works in tablet mode, as well as hibernation on lid close and automatic screen brightness).
  • I was able to dock a window to the right side of the desktop, and then resize it to a thinner column, but I wasn’t able to dock another window to the rest of the desktop… (the smooth 1:1 touchpad zooming to the virtual desktops animation is something I could stare at all day… it’s so good!)
  • Quite surprised to not see a notification duration setting in the settings app under notifications… they go away very quickly, forcing me to click on the top bar to see what they were.
  • I saw something called Zenity on the lock screen, which I don’t know what it is. Hitting the Windows(?) button and searching for it yields no results. However, in the settings app under notifications, it’s listed. That’s quite confusing.
  • In the activities, I can’t just drag an application up to an empty virtual desktop to the left of the leftmost one. I must use the one on the right. But worse, still after having done that I can’t drag the newly populated virtual desktop to the left of the leftmost one!
  • Also, apparently you can drag applications out of the virtual desktop thumbnails in the top row! THAT IS HORRIBLE! At no point do I ever want to do that! I want to rearrange the order only. However, I do want to be able to drag applications from the larger preview in the middle of the screen, and that’s currently not as flexible…
  • Window positions and sizes, especially docked windows, doesn’t seem to get remembered per application after you close them. Reading about this, a technical reason is given that “it’s not Gnome’s job”, but as a user I don’t care. It’s just bad UX.
  • Some apps like Discord apparently have a minimum size, so if you run the desktop at 200% you can’t reduce the size of the window. This makes the lack of good tiling support worse.
  • Lots of apps become pixellated instead of respecting display scaling (200%), like Discord, Steam, Krita, Darktable. EDIT: Seems like some recent update improved upon the sharpness in many apps… it’s not as crystal clear as in the gedit text document I’m writing this in, but it’s better! Oh, turns out that the system update I did only changed my display scale from 200% down to 175% without prompting me.
  • And at 200% display scale, the version history and ability to view when a Flatpack was last updated disappears from the Software App for some reason (regardless of the window size). EDIT: Nope, that wasn’t the issue… sometimes that line of info is just not shown. After a reboot it was back.
  • The software app also shows the loading spinner quite often. When you search for something, and click on a resulting app, you can see the entire page for a split second, screenshots and all and then it disappears and you only get the spinner for a few seconds. Similarly, if you choose to install something and then go back to the search results, you can also get the spinner for a very long time. Why doesn’t the app cache the search results? EDIT: I just uninstalled an app for the first time, and got the spinner flickering into view twice before I was allowed to continue using it…
  • That software app is seemingly also allowed to peg several CPU cores, even in balanced power mode, which I guess I find a bit weird (I downloaded a great cpu temp monitoring app from it, though, which is what made me notice… that and the fans on my laptop).
  • When you have system updates in the Software app, you get a popup to reboot your system before they all are downloaded. So, if you want the update badge to go away, you have to go into Updates and run it several times. EDIT: Today, I clicked download… and noticed that nothing seemingly had happened. Then I saw that the text on the button had changed to “restart & update”… why on earth does it not do this in one go?
  • Looking up if there is an emoji input on Linux, seems the default answers on the web is control plus a key which on my national keyboard layout requires shift, so naturally it doesn’t work. I do not know where to find a setting to change it (or why Linux hasn’t locked it to a hardware key regardless of layout).
  • Using the OBS install which came bundled with my distro was very problematic. The radio buttons in the auto-config wizard didn’t update unless I switched virtual desktops and any button only highlighted and accepted clicks on it’s lower half. Plus, an area around the app began flickering.
  • Also, selecting audio input in OBS left me completely clueless. What is ALSA, PipeWire or PulseAudio? Why can’t I just choose my laptop microphone in plain english? This particular jargon is not ready for a general desktop using audience. Plus, when I just chose one of them, the dialog which came up was just a window with transparent contents. Once I began mousing over, some menus appeared and this might be just an OBS bug but it was a serious one. Watching the resulting video, the audio was absolutely horrible and sounded extremely garbled.
  • I open Files and right-clicked and selected to create a new text file from the context menu. A file named text file was created, but double clicking it pops up a dialog saying it can’t be displayed…
  • Since there’s no rubberbanding, when you reach the end of something it’s actually quite jarring when the scrolling just stops dead. Rubberbanding is a rather recent UI development so it’s fascinating how quickly you get used to something like that. EDIT: Turns out, the only thing in Gnome which has rubber banding are the virtual desktops… why only them?
  • Gnome, Wayland, Mutter… I’ve got a vague feeling of what some of that means, in addition to my distro, but no idea how to check what each version of those I have, and if they get updated via the Software app or something else. Hopefully, since the user isn’t really exposed to those terms unless they go looking for them, it’s all seamless and won’t risk getting outdated over the years. (Someone told me that in the about panel of the settings, you could see version info for that and also a shortcut to update it, and of course, that worked although Mutter isn’t mentioned and the first time I opened the panel, it said “Gnome version not available” until I restarted it.)
  • Gnome Extensions, however, was something I came across talking about Linux, and the extension manager built into the OS was very nice, and recognizeable for a Windows user like me who had used Firefox with extensions previously.
  • I get “the login keyring did not get unlocked on boot” every time, so when I want to run a Mastodon client that pops up. Slightly annoying.
  • Weirdly, I had to download a Gnome extension in order to just get apps to remember what size and location they had. I had to search for how to do that and the extension didn’t have a straighforward name so it wasn’t intuitive to find. EDIT: It also seems to have stopped working after a few days.
  • Discovered that Youtube in Firefox stutters… and the reason is apparently that hardware video encoding isn’t supported on my machine… which is an Nvidia laptop (yes, yes, cue Linux user jokes about that). After very kind extensive community support, it was determined that there was some conflict between the nvidia gpu and some intel gpu on it (it’s a Microsoft Surface Studio Laptop). Something about LIBVA_DRIVER_NAME being forcefully set to nvidia, even if you attempt to launch firefox using intel.
  • After a week of usage, the Software App says that there’s a System Update, but when I click Download it just shows an animation on the button for a little bit, and then nothing happens. Not being able to run a system update feels… bad. EDIT: Nobara recommends using their own bundled System Update app, which so far has not failed.
  • After that same week of usage, whenever I wake the laptop from sleep and log in, the screen goes black for a second. This did not happen during the first couple of days of using Linux. EDIT: Apparently, this seems to be some side effect of some terminal commands I was told to run in a distro support chat in order to try to figure out why Firefox did not do hardware accelerated video… EDIT 2: Oooor maybe not? Because I searched a bit and more people were suffering from something similar, so when I used a tip to rename the .config folder that black screen went away… glad that I could fix it, but made me feel that Linux is quite fragile. EDIT 3: After a system update, and Nvidia driver uninstall and reinstall due to what was going on in the next paragraph, the black screen is back… my positive Linux experience is fading a little bit.
  • Speaking of the terminal, it’s really confusing that you can’t copy and then paste into it using the ctrl-c and ctrl-v shortcuts. Middle click works, but that’s so weirdly Linux (and difficult on some laptops), and also, you get weird characters in front and behind (^[[200~) and you can’t ctrl-c out of the terminal (I see the reason why) but instead have to use a right-click menu. EDIT: After a few weeks, some applications began pasting extremely slowly, and the Clipboard Indicator extension even skipped some simple copied text…
  • One side-effect of me renaming the .config as a fix for the black screen is that the blurry shell background extension stopped working. Whenever I enable it now it’s just all black. So yes, fragile… EDIT: I also noticed that the GPU sensor in Freon stopped working, so maybe it’s actually the Nvidia driver which stopped working when you rename .config? Turns out, yes it was… after running the Nobara removal and reinstallation script again everything is back to normal… yet I don’t see anything Nvidia in .config…
  • The auto brightness worked really poorly, with very big and distracting jumps in brightness which came at annoying irregular intervals and sometimes ended up being far too bright or far too dim. After a week of usage, I had to turn it off because I was manually adjusting to counter what it automatically did anyway.
  • I connected a 4K display (TV) to the laptop via USB-C and it worked nicely, which was a nice surprise. However, when revealing all workspaces, the TV doesn’t appear which is a bit confusing. The only way to put a window on the TV was to drag it to the right of the screen. Also, I’m fairly certain that the second screen doesn’t seem to respect the 2x display scaling on my desktop (things, including the cursor, were super tiny). Then I put the laptop to sleep for the night, and the next day when I turned it on, the dual displays had suddenly swapped places, and my dock and search results was on the TV instead of the laptop, which was not a very nice surprise. Worse, unplugging and re-plugging the USB-C cable did swap the position of the dual displays back, but the start menu and search results were still stuck on the TV…
  • Steam by Valve seems even more difficult to actually close than in Windows. Similarly to Windows, if I press the X on the window, the app disappears but is in fact still running. However, even if I choose Quit from the menu, after I wake my laptop from sleep, Steam pops back up. Sometimes when I go to power the laptop down, Steam pops up. Sometimes Steam’s scrollbars are transparent, and makes the entire desktop occasionally flicker.
  • So after a week, I noticed that Thunderbird finally released their big Solarflare update in the Software App. How did I notice? Well, I searched for the app, and I saw that it was updated (new icon and version number). However, the date of the update was wrong (claiming it released earlier than it actually did) and my only option was “Open”, not update. Also, looking in the updates tab, the app didn’t appear even after a refresh. So I had to uninstall the app and then install it again in order to get the update (only even after I did, the app retained the old icon in the dock and the app gallery… tried multiple reinstalls, but it did not help).
  • After two weeks, seems the Nvidia drivers at some point had replaced some default settings in something called “grub” which removed the quiet boot (according to a very helpful support chat). EDIT: After a few more weeks, everything went back to normal and I stopped having to see pages and pages of terminal output on every boot.
  • Similarly, after some weeks, the Gnome Files app still fails connecting and reconnecting to windows shares, while the Samba4k and Connections apps have no issues.
  • After yet some more weeks, I launched the Extension Manager again, which told me in a notification there were extensions with updates. I noticed an orange icon next to one of the extensions, but clicking on it did nothing. Also clicking on the notification did nothing. I still don’t know how to update that extension.
  • Maybe it was Nobara, but Firefox just stopped working suddenly, and refused to launch even after a reboot. I had to remove the “Nobara” (which apparently is Fedora according to the maintainer) version of Firefox from the Software App and then switch to the “official Flatpack” version in the same app. Seems to be running again now, but all my settings and open tabs got hosed and doesn’t instill confidence about Linux.
  • I wanted to use Subversion as version control for Unreal. In Windows, I install TortoiseSVN, do a checkout via the file explorer and I’m ready to go. In Fedora/Gnome I still haven’t figured it out. Seems I need a command line tool first, and that requires python maybe, and then there might be some gui clients which hook into that… and finally something which integrates with the file manager (which is apparently called Nautilus). It all seems ridiculusly complex, but of course regular developers might be used to that I don’t know. EDIT: So that’s what Google search results told me… if I’d just typed “svn” into the terminal, there would be a helpful prompt asking me if I wanted to install it… however, I’m surprised there was nothing similar in the more modern Software app. Guess devs who use svn are expected to get down and dirty.

Ok, so that’s quite an info dump. Will anyone even read this? Probably not, but it was good to get off my chest. Linux is really slick in most cases, but I must admit that I don’t think it’s ready for prime time yet. I couldn’t replace my mother’s MacOS machine with it, but I’ll stick with it on this laptop and on my main PC I’ll stick with Windows 10 for as long as Microsoft will let me and after that I really hope the apps I need will all have native ports.

Welcome to the community! I initially planned to come with some remarks, but this post is way too long to respond to on its own. I’d suggest reaching out to individual projects with any questions / feedback. The GNOME ecosystem is made up of a lot of both core components and third-party apps, and there is no mouth you can just feed with your issues to make them get to the right place. You’ll have to put in some effort . Make sure not to overload maintainers and other contributors, who often have a lot to do already.

Your distro makes quite a lot of modifications to vanilla GNOME as far as I know, and it’s responsible for many of the things you mention. I’d check if it has any community spaces you could get help in.

You mention that you tried theming, which, contrary to what a lot of people believe / want to believe, is not a supported feature in GNOME. GNOME supports dark/light styling, and official accent color support is being worked on. Outside of that you’re in unsupported territory, and any visual bugs should be reported to whoever provided you with the customizations, not app / shell developers. If you want a stable and predictable experience, you should avoid unsupported customizations.

Good luck on your journey!


Mostly no.

You should at least categorize them with headings ( General / Files App / Software App / Drivers etc ), so people can comment on their topics of expertise.

That would be surprising as to my understanding it’s mainly compability patches and QoL things added. I’m also using the more or less vanilla Gnome variant.

That sounds like a good idea, however this forum apparently doesn’t allow edits?

It does. Don’t you see edit button at the bottom of your post ?

Those “QoL” things you mention means it is not vanilla GNOME. Anything related to modified UI/UX means you need to complain to your distro customizer rather than GNOME.

For instance, one thing that instantly brings suspicions that you are not actually running a vanilla GNOME here is that you keep mentioning the “dock”. Outside of the Overview mode’s temporary “dash” bar, GNOME does not have a dock. It was not designed for it, and all of the related things (minimize button, etc.) are not present in vanilla GNOME, and thus not accounted for. If you are running a modified GNOME, you are technically not running the “GNOME UX as designed”.

Anything LibreOffice is a LibreOffice bug. It has 7 different UI layouts variants and multiple GUI toolkits, and as a result, thousands of bugs in its toolbars alone (I know because I frequently report issues in their Bugzilla, and I can see them all). Nothing to do with GNOME per se.

I frequently make use of this feature. Just because you don’t see the need for it doesn’t mean it’s horrible.

Those are all non-GNOME apps, and specifically, none of them are using GTK.

We can do nothing about nVidia. Their proprietary and undocumented blackboxes are notoriously unfixable. You are exactly in this situation, and you will get the exact same reaction as Linus from anyone. You want to run Linux without pulling your hair out? Get a machine with Intel open source graphics, or (as a compromise) AMD open source graphics.

Those are good points, in my personal opinion. See issues related to the Mouse & Touchpad section of GNOME Settings / Control Center. You probably would need to go through the design team’s whiteboards process to get a solution agreed and designed first before implementation, otherwise it may be hard to convince developers to touch it.

You can silently subscribe to this issue to be notified of resolution.

It’s a proprietary, non-GNOME app. Please report the issue to Valve.

I think you see the pattern by now: 90% of the problems you are encountering are not GNOME’s fault nor responsibility, nor within its range of action.

For the remaining issues that are specific to GNOME apps in an OS that actually ships the latest vanilla GNOME then you would have an easier time finding what existing tickets have been reported about each app in GNOME’s GitLab and subscribing to them.


Fedora and ubuntu allow you to automatically report crashes.

I suspect you’re using smb, if you can try nfs

Applying updates on a running desktop can have side effects. Users get broken UI, think they are in the new app, while they are not, background stuff might not actually update etc.

Sorry, when I wrote QoL I meant things like Nobara supplying an app which automatically installs Nvidia drivers and media codecs and keeps them updated.

Also, since I’m a first time Linux user, I don’t know what everything is called. It looks like the MacOS “dock” so that’s what I’m calling it (even though, as you say, it’s only visible when you hit the “spotlight/expose” shortcut key). :wink:

The GNOME desktop is still unmodified, as I pointed out.

I wonder if you’re an advanced user, though? Because to me this feels like an advanced use case which should at least require some sort of modifier key (like shift or control) to trigger.

I guess this is why Linux has such problems breaking into the mainstream desktop. Nobody is in charge of the complete experience… I think it would be beneficial if every window (or app) had a built-in bug submission form (similar to Blender)…

Thanks for the information! I’m glad one of things in my list was apparently a five year old issue that’s finally getting resolved! :partying_face:

That doesn’t appear to be a supported option to a newbie like me…

It’s impossible to be in charge of everything. The Linux desktop apps collection represents multiple hundreds of millions of lines of code, in different languages, using different technologies, with different technical expertise needed in each area. LibreOffice by itself has 10 million lines of code, the kernel has over 30 million, each browser engine has over 25 million, etc.

Apple is not in charge of bugs in Adobe products either.

Also, Apple makes 400 billion USD in yearly revenue; they’re basically printing money at this point, and can afford to pay many people to maintain their core apps that come with MacOS. But as a consumer, they’re not going to give you personalized white-glove service to fix software bugs everywhere in the stack, you will still have to report them at the right places.

Otherwise on Linuxland, if you want a single person to talk to and fix all your bugs, that’s an enterprise SLA / support contract, that you pay one of the consultancies or distro/software vendors for.

They kinda do. The “About” dialog of most GTK4 GNOME apps, and their flathub pages, have links to their specific issue trackers, wherever they are.

1 Like

Right, you will need to install gvfs-nfs

sudo dnf install gvfs-nfs

And your nas needs to have nfs enabled

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.