GNOME 42.5 how to disable activities/overview on login

Hi All, I’m creating a kiosk with GNOME 42.5 on ubuntu 22.04 with the account automatically logging in and launching either a video or a web browser in kiosk mode. Unfortunately every time the the system logs in it goes directly into the activities overview display, because this display will not have direct access to a keyboard or a mouse this won’t work for me. Is there any way we can have the activities overview not be the default thing you see on login and have the application I’ve set to launch on login take up the whole screen?

I believe this was initially discussed in this thread [GNOME 40 login is to the activities/overview mode, how do you disable this?] but from what I see nothing came of it as it didn’t appear anyone had a valid use-case for not having the activities overview be the default greeting upon login.

This is my view upon login if my reference is inaccurate:

If I remember correctly, there is an extension for that. I don’t remember its name but you can search for ‘activities’ on extensions website or the Extension Manager app and you’ll probably find something that fits your needs.

1 Like

Thanks for the prompt reply, i found an extension however I have concerns with deploying it.

I will be deploying quite. Few of these machines in a kiosk mode and they will be in the wild with minimal supervision. My concern is during a regular patching cycle this breaks because it’s not officially supported by gnome or Ubuntu and currently I don’t have a method to automatically enable this shell extension via something like Ansible which adds a layer of manual intervention that I’m trying to reduce.

When I install the Ubuntu desktop version it doesn’t have this enabled what does that version of gnome have that the minimal version does not.

Thanks

Ubuntu disables this via its ubuntu-dock extension (which is based on dash-to-dock).

Thanks for that, I tried to enable that extension and it didn’t work as expected. lets see I go down the road of using No overview at start-up - GNOME Shell Extensions
the only way i’ve been able to find I can enable this extension is to physically login to the machine and using the extensions application flip it to on.

I’ve tried to enable using gettings as root for system wide shell extensions stored at /usr/share/gnome-shell/extensions and running commnad: gsettings get org.gnome.shell enabled-extensions

or by using the user account in question and storing the extension locally and running the same command.

sorry if i’m missing something big here but I can’t seem to turn on this extension without manual intervention on the machine in question
ideally I need the ability to enable this extension remotely without X11

Thank you in advance,

Your command just prints a list of extensions that are set as enabled. You should be able to enable already installed extension using the following command:

gnome-extensions enable [uuid]

The uuid is an id of the extension, you can find it in extension’s metadata.json file and also as a name of the directory in which the extension is installed (in Ubuntu double Tab after the enable will show you available uuids).

To change the system-wide extensions enabled by default you would have to do something like described in Custom default values for system settings.

The settings key and format for enabled extensions is:

[org/gnome/shell]
enabled-extensions=['no-overview@fthx']

This is a list and you can add multiple extensions separated by commas.

System wide extensions are installed in /usr/share/gnome-shell/extensions/ where the name of the subdirectory for each extension has to match its UUID as specified in metadata.json, e.g. /usr/share/gnome-shell/extensions/no-overview@fthx.

Thanks for the info,

it’s gotten me out of a bind for the time being, long term I would like to know if there is any consideration to disable this overview at launch without a custom shell extension. My concern is long term support of the shell extension if it breaks due to a new release or update of Gnome.