Focus on autostart application by login

When I log into GNOME 40, the workspace list is shown, which shows the default two workspaces but the primary workspace is not acitve until I click the workspace.

I run gnome-terminal from XDG_CONFIG_HOME/autostart by login and wish to focus on gnome-terminal immediately without any mouse or keyboard operations and could done the behavior in the previous GNOME versions.

Do you have any ideas to focus on the primary workspace by login or maybe adjust the number of the workspaces?

The session now starts in the overview, see this discussion

If you disable dynamic workspaces, you can set a fixed number:

$ gsettings set org.gnome.mutter dynamic-workspaces false
$ gsettings set org.gnome.desktop.wm.preferences num-workspaces 4
1 Like

Thank you for your replies.

My autostart application cannot get the focus when I disable dynamic-workspace and set num-workspaces to 1. I could cancel the overview mode with Escape key but unfortunately the way would not be useful for my applications because the Escape key needs to be sent to desktop.
I’d like to have an option to start the session in the desktop mode instead of the overview mode so that the autostart applications get the focus by default.

That’s an “unbreak my desktop” option.

The proper fix is to not go to the overview if the applications are auto-started; the problem is that there’s some racy behaviour when it comes to autostarting, which makes it tricky.

Probably I will file a RFE for gnome-shell later.
Personally I prefer the desktop mode to the overview mode by default and I wish not to go to the overview mode if the applications are auto-started at least.

1 Like

We already have https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/3854.

2 Likes

I find it cool to start in overview mode.
Another user told me he was not happy with it, so I did:
https://extensions.gnome.org/extension/4099/no-overview/
(at the moment: https://extensions.gnome.org/review/22846)
Hides the overview at session startup.

I agree that an option could be proposed through Tweaks or GNOME prefs, to enter overview at startup or not.

2 Likes

Thank you for the link.

Thank you. I will try to use the extension.

@fthx I tried no-overview@fthx with gnome-shell-40.0 but it does not disable overview mode.
I checked gnome-extensions list --user and gnome-extensions info no-overview@fthx shows INITIALIZED state.

You mean that overview mode is still activated at startup?

@fthx Yes, I mean it.

% ls $HOME/.local/share/gnome-shell/extensions/no-overview@fthx
extension.js  metadata.json

Well that’s quite odd.
I do use a Fedora 34 VM and it always works at startup.
Is there any error message in Logs (search “fthx”)?

@fthx Sorry, my mistake.

I forgot to change the value of disable-user-extensions in org.gnome.shell gsettings and now I enable the no-overview mode.

Good! This will remove an item in my todo list!

@fthx I will package no-overview extension for Fedora DNF next week. I’m also fine if you will do. Thank you!

2 Likes

I do use Ubuntu. :slight_smile:
I just run a Fedora 34 VM for GS 40 testing.

2 Likes

I answered you on GS website.
Just to tell you I’ve just made this:


It should be easier for you.
1 Like