Change the screen dimming delay

GNOME dims my screen after 30 seconds of inactivity in Power Saver mode.

This happens even though I have “Dim Screen” turned off in Settings. I don’t mind it, although being consistent and being able to set this separately for each power profile would be better.

However, the delay is way too short for me. Can I change this value in the Dconf Editor or somewhere else? I am using GNOME 43.9 in Wayland mode.

Yes, I think you can set it via dconf editor at:


The setting is idle-delay and the value is in seconds.

Though keep in mind that adjusting this setting will affect all power profiles. Unfortunately, I don’t think GNOME provides a built-in option to set this separately for each power profile, at least for now. Hope this helps. :grin:

Thank you @maxrdz, but I don’t think that value controls the dimming delay. It it set to 1200 (seconds) for me, and I set it to that value to control screen blanking, not dimming, based on this (which, by the way, worked):

Oh I’m sorry, I misunderstood your question.

I tried looking over /org/gnome/settings-daemon/plugins/power/, but I did not find a value related to the dimming delay, I only found a value for the brightness of when the screen dims the first time, before the screen blanks. Sorry if I am not of too much help; I am not very experienced with GNOME, but hopefully a more advanced user can answer this.

1 Like

In power saver mode the screen dimming delay is hardcoded to 30s: plugins/power/gsd-power-manager.c · master · GNOME / gnome-settings-daemon · GitLab