Wun Gimp 2.2 Pango-ERROR fix, may happen in other versions as well

I use Gimp 2.2 which requires GTK+ 2.4.14.

Recently I recieved this error again as I had this happen before…

Pango-ERROR**: file shape.c: line 75(pango-shape): assertion failed: (glyphs->num_glyphs>0)
aborting…

I read about it on some other sites, but I wanted to post it here so people can get a workaround for this error from the main GIMP related message boards.

First, I uninstalled my current GTK+ Runtime from Program Files (x86).
Then I deleted the remaining folder.
After that I installed GTK+ 2.4.14.
I still recieved the error, so I copied all of the DLLs from GTK+ Runtime\bin
to the main GTK+ Runtime folder.
Then it started working. I’m not sure why this happens because it was working at one point before I used a Restore point, then it started acting up.

Now it works fine. I hope this helps anyone else getting this error message.

Cheers!
Bee

Why do you use GIMP 2.2? 2.2 was released in 2004. That version has been deprecated for over a decade. GTK 2 was deprecated 13 years ago. It’s time to upgrade.

1 Like

For some reason, I tried 2.6 up to the new version and i cant get the crop tools to work correctly. Which affects my connect the dots outline selection and cutout methods. When i use crop in 2.2, i’m able to set the crop with an x & y axis by pixels which allows me to make precise crops. I havent figured out how to do that with current versions. If youd like, i can show you some of my creations. Most are adult oriented collage type desktops using photo sets. Theres always some fine tuning which allows me to make the art seamles.very difficult to find the imperfections.

Thanks for your response!
Bruce

1 Like

The “new” crop tool (I guess its more than 15 years old already) is quite capable of any work needs you have. It along with the rectangle selection tool were the subject of an extensive UX work by a team of volunteers, and I don’t think its usuablity for production use is matched in any other software. However, it differs from the previous interface.

just check the box on the drop down that reads “Fixed Aspect ratio” on the tool options, and then change it to “Fixed Size” - then just fill in the values and units in the form bellow that.

That said, you should really be running the last stable GIMP - 2.10.38, and soon, 3.0.0 to leverage all the new features in the software

1 Like

Thanks so much. Ill try that. fingers crossed