Why clicking shell top bar focuses maximized window?

I’m using gnome 3.38.4 on Fedora 33 (with Wayland). I have dash-to-panel extension activated, but the behavior is the same without it. I usually have Chrome window maximized. And whenever I click on the top bar, in an empty area, the Chrome window is brought to front. This does not occur when there’s no window maximized. As fas as I remember, this didn’t occur on Fedora 31.

Mouse click is one thing, but it seems that the top bar area is somehow associated with the maximized window, as I noticed other odd behaviors:

  • click in top bar empty area and start moving mouse => the maximized window starts moving with the mouse
  • move the mouse up from desktop area to top bar empty area, passing over a tab in the maximized Chrome window => tab popup/tooltip appears in Chrome, even though the mouse is not over it

Is this by design?

Is this by design?

Yes. Maximized (or tiled) windows can be restored (i.e. unmaximized/untiled) by dragging them, and that behavior was extended to the top bar a long time ago (in 3.4.0).

1 Like

Yes. Maximized (or tiled) windows can be restored (i.e. unmaximized/untiled) by dragging them, and that behavior was extended to the top bar a long time ago (in 3.4.0).

Is it possible to disable it? While I understand the drag-to-unmaximize concept, bringing the maximized window to front by simply clicking the top bar empty area is a rather odd behavior IMO. And Chrome showing tab tooltips randomly while the mouse is not even on top its window is getting rather annoying.

Is it possible to disable it?

No, unless there’s some extension that implements that.

And Chrome showing tab tooltips randomly while the mouse is not even on top its window is getting rather annoying.

I don’t see how that’s related.