Why are my mounts listed in the sidebar?

For a while now, my NFS mounts have been showing up in the left hand sidebar of Nautilus. I’m curious why they would do so. I’ve been mounting them via AutoFS, and just switched to SystemD unit files today. They show up when using either mount system.

I’d expect that removable drives, or mounts initiated via Nautilus would show up in the sidebar. Mounts outside of Nautilus I’d expect to be treated as normal folders.

While searching about it, I found some mentions of Nautilus only being supposed to list mounts in /mnt or /media. FYI, my mounts are in /home/user/shares.

Plus, my mounts are listed twice in the sidebar. (That’s somewhat new behavior. Started a while after I did a reinstall. I did restore my home directory, so I cant say it’s a clean install…)

So I’m unsure on if what I’m seeing is expected behavior, or not.

Is listing nfs mount in the sidebar expected? If so, any idea why they’d be there twice?

I’m running Pop!_OS 20.04. So Nautilus 3.36.3-stable.

Thanks in advance!

2 Likes

Hi.

It looks like a bug. It reminds me of https://gitlab.gnome.org/GNOME/gtk/-/issues/1474

Maybe the x-gvfs-hide mount flag can help you too.

1 Like

Would this be how I’d apply the x-gvfs-hide flag in a .mount unit?

[Unit]
Description=Mount /home/user/shares/general

[Mount]
What=freenas:/mnt/export/general
Where=/home/user/shares/general
Type=nfs
Options=x-gvfs-hide

[Install]
WantedBy=multi-user.target

x-gvfs-hide is one of the things I ran across while researching. When I applied it via the .mount file, it made no difference.

I do have an .automount for each of my .mount’s. But I don’t think you’d apply filesystem options there.