Which library contains the workspace-indicator extension?

I want to change the MAX_THUMBNAILS setting. Looking at this thread here

I tried editing the file /usr/lib/gnome-shell/libgnome-shell.so but didn’t see the symbol there. Is it encoded into in a different library?
The command

find /usr -name *.so 2>/dev/null | xargs strings | fgrep MAX_THUMBNAILS

didn’t show it being anywhere.

The extension should be in /usr/share/gnome-shell/extensions/workspace-indicator@gnome-shell-extensions.gcampax.github.com or ~/.local/share/gnome-shell/extensions/workspace-indicator@gnome-shell-extensions.gcampax.github.com, depending on how you installed it.

Keep in mind that updates to the extension will overwrite your changes so you will either have to re-apply them again or create a copy of the extension with a different name (make sure to also adjust the metadata.json as well as the directory name).

I tried editing the file here


but it didn’t have any effect. Is there something that I need to do to get it to load?
Just re-booting didn’t change anything.

One thing I notice is that, inside the dconf editor, I can go to
but there’s no entry for gcampax or workspace-indicator there.
I looked in the other sub-folders but didn’t see anything similar there either.

I was wondering if disabling/enabling the extension would enable the edit that I made.

Ok – this is enough of a solution for me:

sudo vi /usr/share/gnome-shell/extensions/workspace-indicator@gnome-shell-extensions.gcampax.github.com/extension.js # Adjust the MAX_THUMBNAILS

gnome-extensions disable workspace-indicator@gnome-shell-extensions.gcampax.github.com

gnome-extensions enable workspace-indicator@gnome-shell-extensions.gcampax.github.com

I’m going to close this for now. Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.