What to do when being unable to recover a GitLab account?

I did not find any support email or things like that so I guess this is fine enough place to put this, after all this is something that “do not fit an issue on GitLab” as I can’t access GitLab due to an account problem.

So my issue is that no matter what SSO login option I use I get a page like:

page text for searchability

using GitLab.com auth failed

failed because Email has already been taken.

Try logging in using your username or email. If you have forgotten your password, try recovering it

I’ve tried the account recovery multiple times with the exact same email as on my accounts I use to login, but I have received 0 password reset emails (I did check my spam folders).

This started a while ago when I think I forgot which login option I had used and then probably used a different one and then tried to do an action that prompted for a password, but I can’t remember ever setting one. Then at one point I tried to login again to solve that problem but I was never able to login again. So basically I think my account on GitLab is in some weird state where it cannot be recovered. This is not exactly the same as a GNOME account for which all advise on changes seems to be to post an issue on GitLab, but nowhere did I find anything saying what to do if GitLab doesn’t let me in.


what’s your username?

Same as here, I think. At least my email on this account should be the exact same as the one I’m trying to login to GitLab with.

Please try recovering your account again now :slight_smile:

1 Like

I received the password reset email now. Thanks for the help.

Hi, I have the same issue: I have a Gnome account which works - I can login to extensions.gnome.org/ for example, so my password is correct - but I’m unable to login in gitlab.gnome.org :

I get the error message "Could not authenticate you from Ldapmain because “Invalid credentials”

And when trying to log via Github or Gitlab, it fails with Error 422 : “Sign-in failed because Email has already been taken” - I use the same email for those accounts.

My username is Valeryan_24


I reactivated your account, you should be able to reset your password now, thanks!

I am facing the same issue.

Not receiving any mail from gitlab for password reset and when I try to signin it says email already exist.

praveen.mishra@comakeit.com is my account id

What’s your username exactly?

If I do not remember the user name can I reset my password ?
Please help me out here it’s my official mail account and I am stuck.

Can’t find any account associated with that email, it was much likely pruned by our automation due to inactivity, please register a new one, thanks!

I received an email on 1 Dec telling me my account (edj) on GitLab had been deactivated and to login to reactivate. Now it won’t let me login, and requesting a password reset does not send an email.

What should I do?

Please, join the #infrastructure:gnome.org channel on Matrix (or #gnome-infrastructure on libera.chat) to contact the GitLab admins.

Thank you! I separately got told to use the “Sign in with… GNOME Keycloak” which let me log in with my existing username and password, which then said my account had been reactivated.

It’s not at all obvious that is the right thing to do, and ideally would be added to the text of the sign_in page.

Sorry to have bothered you folks, and thank you for the impressively quick reply.