What causes "bwrap: execvp <my app name>: Permission denied" -flatpack

btw im a noob so patience pls :>

So im Making a Gtk4 App and Used Gnome Builder IDE And i uploaded it to a git repo

~ still learning git btw

and after trying to get a clone then building it it builds successfully but running it gives me that error : bwrap: execvp <my app name>: Permission denied

i dont know what caused/es that and i cant even find anything online can help
what is this and why would that happen :confused:

Generally that means that Builder couldn’t find the program in the search path when running it.

But if you’re running our Nightly build (the GTK 4 port), then it could be a whole host of things as the port isn’t finished yet.

1 Like

Maybe mushroom.in file is not executable! Make it executable by running the following command and then try to build and run the app again.

chmod a+x src/mushroom.in
1 Like

tried chmod but it seems like that file permissions was not the issue
but instead i cleaned some caches and it worked strangely
thank u all for ur help :heart:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.