Wayland is not available, GNOME 42 running on X11

Distro is pure arch, nvidia drivers are at version 515.57. By default I should be seeing GNOME, GNOME Classic, GNOME on Xorg and GNOME Classic on Xorg options on GDM but I just see first two options that I mentioned. When I login to my user and check Settings → About page, the Windowing System is X11. I tried to make WaylandEnable=true in custom.conf, didn’t help. I don’t know what is wrong in this case, Nvidia driver running just fine. It’s set to run on initramfs (MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)), drm kernel mode also set to run in GRUB config.

after creating a symbolic link with ln -s /dev/null /etc/udev/rules.d/61-gdm.rules and restarting the system, I have four session options in GDM available and the default is Wayland now. Is this the correct way of enabling Wayland for nvidia users even tho they have driver higher than 510?

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.