Wayland don't found after login

Hello! I would like to report a problem that occurs from gnome 45 to 45.4, my notebook is a dell inspiron 3501 i5 1135g7 32gb of RAM. When starting the wayland session it stops on a gray screen, I can’t move the mouse and the keyboard doesn’t even work. It’s my favorite Linux environment, and unfortunately I can’t use it. When logging into the wayland session the gray screen persists, I try to use the shortcut keys to enter the prompt and I can’t, I try to move the mouse and I can’t! Essi occurs in all the distros I tested, the same problem. If you can solve it for me and anyone else having this problem, we would appreciate it!

What is logged to the journal when this happens?

So my friend! I couldn’t see him! Even gnome 45.5 is like this! It’s impossible to use it! Don’t log in! I did a test when I log into X11 and it works, then I log out and enter wayland, only that way which is frustrating!

what distros did you tried?

Hello friend then! I was testing on all of them and still the problem persists. This afternoon I decided to test something different, I downloaded archlinux and did a different installation, I used the option: Nvidia (open kernel module for newer GPUs, Turing+) as driver and unexpectedly it worked, this error occurred when I used intel open source. I believe this is the problem I was facing not only in Arch, but in Ubuntu, Fedora, etc. I don’t know if it’s something in Mesa Driver or the Kernel, I just know that it’s impossible to use in other distros. I don’t know if it’s because it’s a hybrid chart. One thing is for sure, it’s not logging in, the mouse freezes, a gray screen appears and it stays there and doesn’t even go back to the login screen. That is until I use the option I mentioned → “Nvidia (open kernel module for newer GPUs, Turing+)” I’ll keep testing for now, nothing has been revealed, but if so, I’ll get back to you here!

Captura de tela de 2024-03-17 20-05-10

Thank you in advance friend!

yeah, open source drivers may be issue here, wayland and nvidia don’t
like each other, it is not gnome problem but wayland being bad

I understand! I hope for a correction soon, thanks for your attention guys!

It’s not “Wayland” (which is a protocol), but the closed source nVidia driver only recently supporting the necessary infrastructure for implementing display managers outside of X11.

Yes! Testing so far with this configuration, it seems that Wayland is starting normally! I hope in the future wayland can be improved

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.