Virtual Keyboard not showing on Phosh Shell


I use Manjaro Gnome on the Radxa Zero. To use it on a 5inch touchscreen I installed the Phosh shell. On the normal Manjaro Gnome shell the virtual keyboard works fine. But with the Phosh shell it doesn’t works.

I enabled the virtual keyboard in the settings and the keyboard icon is showing in the right buttom of the screen. But the icon is disabled.
Do I have to install some extra packages?

Phosh uses Squeekboard, and it might be bundled with it. I’m not sure.

Yes I found this out by googling too. So I searched for it in the store and it was not installed. But after installing it, it doesn’t shows too. I can open it in the Appoverview but it doesn’t shows when I select a input field and the button in the bottom is still disabled.

I solved it by installing squeekboard and adding the file overlays/phosh/usr/bin/osk-wayland · master · manjaro-arm / applications / arm-profiles · GitLab.
Then the file have to make executable with sudo chmod +x /usr/bin/osk-wayland

After restart the virtual keyboard shows like expected.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.