Version Numbers are counting down?

I’m confused: Is Jens taking a time machine to publish a newer version in the past?
Screenshot Apps/Shotwell - GNOME Wiki! :

image

I have installed this: https://gitlab.gnome.org/GNOME/shotwell/-/raw/master/flatpak/org.gnome.Shotwell.unstable.flatpakref
Looks like the newest version is 0.31.2

There’s no GtkTimeMachine here. It’s just that 0.30.12 is a minor release of the previous version. That happens a lot and is why you can have updates for e.g. 3.38.4 when GNOME 40 is already out.

See https://gitlab.gnome.org/GNOME/shotwell/-/blob/shotwell-0.30/NEWS#L1

That probably misses a <release> tag in the appdata file.

The last stable release is 0.30.12. The last unstable release is 0.31.3.

I know this is the GNOME discourse so please forgive me when I mention Discover… It shows me some flatpak related errors on startup every time. I assume that’s related to why I can’t see the newest version. Anyone knows the remedy?

on the command line:

flatpak update
Looking for updates…
F: Warning: Treating remote fetch error as non-fatal since runtime/org.gnome.Shotwell.Locale/x86_64/unstable is already installed: No such ref 'runtime/org.gnome.Shotwell.Locale/x86_64/unstable' in remote shotwell2-origin
Info: org.gnome.Platform//3.36 is end-of-life, with reason:
   The GNOME 3.36 runtime is no longer supported as of February 13, 2021. Please ask your application developer to migrate to a supported platform.
Applications using this runtime:
   org.gnome.Shotwell
F: Warning: Treating remote fetch error as non-fatal since app/org.gnome.Shotwell/x86_64/unstable is already installed: No such ref 'app/org.gnome.Shotwell/x86_64/unstable' in remote shotwell2-origin
Nothing to do.

Or I may have forgotten to actually build the flatpak for that version :thinking: Have to check.

But yes, this is the latest development version and it’s much older than the latest stable. Because time. and motivation.

It could also be that the repository is massively hosed. Try to install shotwell from gnome nightly, that’s more or less matching 0.31.3 anyway.

1 Like

Is it safe when I remove this shotwell and install the one from gnome-nightly? Will my settings stay?

flatpak list        
Name                                           Application ID                                  Version        Branch         Origin                 Installation
SWH                                            org.freedesktop.LinuxAudio.Plugins.swh          0.4.17         20.08          flathub                system
default                                        org.freedesktop.Platform.GL.default                            19.08          flathub                system
Mesa                                           org.freedesktop.Platform.GL.default             21.1.4         20.08          flathub                system
nvidia-460-84                                  org.freedesktop.Platform.GL.nvidia-460-84                      1.4            flathub                system
Intel                                          org.freedesktop.Platform.VAAPI.Intel                           19.08          flathub                system
Intel                                          org.freedesktop.Platform.VAAPI.Intel                           20.08          flathub                system
openh264                                       org.freedesktop.Platform.openh264               2.1.0          2.0            flathub                system
Freedesktop SDK                                org.freedesktop.Sdk                             20.08.14       20.08          flathub                system
GNOME Application Platform version 3.36        org.gnome.Platform                                             3.36           flathub                system
샷웰                                           org.gnome.Shotwell                                             unstable       shotwell2-origin       system
Breeze Gtk theme                               org.gtk.Gtk3theme.Breeze                                       3.22           flathub                system
KDE Application Platform                       org.kde.Platform                                               5.14           flathub                system
KDE Application Platform                       org.kde.Platform                                               5.15           flathub                system

For whatever reason Shotwell is listed in Korean. How do I do this?

It should just work. The setting still “leak” to your host dconf, and the app folder should be identical. (~/.var/app/org.gnome.Shotwell)

1 Like

Confirmed! Thanks.

image

flatpak run org.gnome.Shotwell

(shotwell:2): GLib-GIO-WARNING **: 20:41:49.265: Can't find module 'dconf' specified in GSETTINGS_BACKEND

Anyone has this flatpak thing figured out? I’m trying to get rid of that error about the remote shotwell-origin, shotwell1-origin and shotwell2-origin.

However:

flatpak remotes
Name          Options
flathub       system
flathub-beta  system
gnome-nightly system

they aren’t listed. sudo flatpak repair unfortunately didn’t do the trick.

You need to use

flatpak remotes --show-disabled

to see the full list (though it should have showed up in the original list if the shotwell-origin remote isn’t disabled). But what I suppose happens is that the *-origin remotes aren’t really proper remotes, you can’t update from them. They are only there as dummy remotes when you install a flatpak bundle (e.g. from the CI artifacts or when exporting a flatpak bundle from GNOME Builder).

So removing the shotwell coming from the *-origin remote should likely fix your issue. flatpak list --all | grep -i shotwell should show you all installed Shotwells, at user or system installation level, and the flatpak bundles.

1 Like
flatpak remotes --show-disabled
Name             Options
flathub          system
flathub-beta     system
gnome-nightly    system
shotwell-origin  system,disabled,no-enumerate,no-gpg-verify
shotwell1-origin system,disabled,no-enumerate,no-gpg-verify

flatpak list --all | grep -i shotwell
샷웰    org.gnome.Shotwell              master  gnome-nightly   system
Shotwell translations   org.gnome.Shotwell.Locale               master  gnome-nightly   system

trying to remove them:

sudo flatpak uninstall --unused
Nothing unused to uninstall

Figured it out:

flatpak remote-delete shotwell-origin 
flatpak remote-delete shotwell1-origin 

that will remove it.