User prompt on lock screen

System: Fedora Linux 37 (Workstation Edition)
Kernel: Linux 6.2.8-200.fc37.x86_64
GNOME Shell: 43.3

The guidelines at Displaying a user prompt on the GNOME login screen :: Fedora Docs allowed me to get rid of username at login screen. Now you have to input both: username and password to login. Perfect. The problem is, that after logging, if I lock the screen (either auto-lock or manual Super+l) the username is there again at lock screen. Is there a way to enable user prompt at login screen instead of just entering the password itself?

Not really. That’s because what you get when you lock the screen is not the login screen. The lock screen is still part of the user session, in fact the UI is provided by the same gnome-shell process that also handles the unlocked session.

As a partial workaround, you can use “Switch user” instead of super+l/“Lock screen”. That will lock the active session and switch to the login screen, where the disable-user-list setting applies. If you log in as a user who already has a graphical session open, the existing session will be unlocked instead of creating a second one, so that should be close to the behavior you want.

OK. And how do I do that? I’m fairly new to Linux systems and unless you could point me in the right direction with some links covering this issue, I won’t know what to do with your answer. :slight_smile:

Switch User is in the Power Off menu but only if there are multiple user accounts (otherwise there’s nothing to switch to). If yours is currently the sole user account the Switch User option is not shown. You would have to create a 2nd user account for Switch User to be shown.


However I don’t know how you would invoke Switch User with a keyboard shortcut. I think it’s not available in the standard keyboard shortcuts and I don’t know of a command to invoke it. Maybe somebody else will.

Correct, there is no “switch user” shortcut. It’s something a small extension could provide.

(ctrl+alt+f1 somewhat works as well, but it will not lock the active session)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.