Use GNOME Builder to build and run a project on a mobile device

Hi everybody :wave:
I am running GNOME on a PinePhone and I’m trying to learn how to make apps for it.
I started by creating a “hello, world” project with Builder. I can run that on the desktop.
Then I successfully connected the device with the desktop using deviced, by following the steps in a tutorial.
I can see my device in the Omni Bar and I can start building it with the Run button.
My problem is that the build process fails at some point (apparently during the install step).
The last few lines in the Build Output are:

Running custom install script '/home/cosmin/projects/hello/hello-builder/build-aux/meson/'
flatpak build-finish --command hello-builder --share=network --share=ipc --socket=fallback-x11 --device=dri --socket=wayland /home/cosmin/.var/app/org.gnome.Builder/cache/gnome-builder/projects/hello-builder/flatpak/staging/aarch64-master
Not exporting share/applications/mimeinfo.cache, wrong extension
Exporting share/applications/ro.hume.cosmin.hellobuilder.desktop
error: regfile copy: Invalid argument

I started builder with flatpak run org.gnome.Builder -vvvv and the only log line that’s not on the DEBUG level says:

20:16:19.2803                           ide-run-manager[    2]:  WARNING: Child process killed by signal 1

Does anyone understand what’s wrong?
Or where could look for more details?

Hi, I am having the same problem, in a less specific situation, and I can reproduce it very easily. I could not find out yet why it occurs. I will report this as issue in gnome builder’s gitlab project.

  • I am using GNOME Builder 42.alpha1 flatpak nightly
  • I start a new python GTK4 project using GNOME Builders “Start new Project” screen
  • A progress bar starts running to download SDKs, but stops running after about 30% of progress.
  • The build information in the window bar displays: “Runtime missing. There is a problem with your current build configuration”. I can solve this issue by going into the build preferences and selecting a runtime. In this case, I chose flatpak org.gnome.Platform 41. As a result, the runtime version changes from “master” to “41” in the flatpak builder json file.
  • Initial success: Now the app builds successfully and I can run the app by clicking the play button.
  • Subsequent problem: Exporting a bundle fails with the same error message:
Not exporting share/applications/mimeinfo.cache, wrong extension
Exporting share/applications/io.github.johannesjh.testp.desktop
error: regfile copy: Invalid argument
1 Like

Ticket for this issue over at GNOME gitlab:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.