Usage of 3rd party components on GNOME Discourse

Hi,

A subscribe on gnome-shell-list asked if GNOME Discourse makes use of 3rd party components. See the email here. Quoting that email:

Lots of Discourse instances are full of incompatibilities with strict CSP and SOP protections.

Not sure what is meant with SOP. I assume GNOME Discourse will only ever make use of Free Software, right?

Same-origin-policy (https://developer.mozilla.org/en-US/docs/Web/Security/Same-origin_policy)

We have the Discourse container hosted on our GitLab instance. That includes the plugins we currently use, as of October 2020:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.