Unable to type Bengali characters correctly in GNome with ibus m17n engine

I’m experiencing writing issues with Gnome and some websites like Facebook when using the iBus M17N input engine. Specifically, I’m unable to type Bengali conjuncts (যুক্তাক্ষর) correctly. However, the issue doesn’t persist in LibreOffice type application

Steps Taken:

  1. Verified that iBus M17N is the selected input engine.
  2. Restarted iBus and Gnome.
  3. Updated Gnome and iBus to the latest versions.
  4. Checked for any relevant settings in Gnome and iBus configurations.

Observations:

The problem seems to be specific to certain websites and applications. Typing Bengali conjuncts works as expected in other contexts, such as LibreOffice and text editors.

Screenshot from Facebook (with problem): (tried with Chrome, Firefox, Edge, and the problem remains with Gimp too)

Screeshot from LibreOffice:

Request for Assistance:

I kindly request assistance from the Gnome community in resolving this issue. Any suggestions, workarounds, or potential fixes would be greatly appreciated.

Additional Information:

  • Gnome Version: from 40, I didn’t try below 40
  • iBus Version: 1.5.30-rc3 (Now)
  • Operating System: Various, I tried with Ubuntu, Manjaro, Debian and Fedora. Now I am using Fedora 40.

Thank you for your time and attention to this matter.