Unable to save gnome application settings ( gnome-tweaks or gnome-terminal )

Hi All,
We are using gnome session 2.32.0 with the tiger VNC on Centos 7 OS.
We noticed a strange issue where we are unable to save the gnome application settings
We tried using gnome tweaks to modify Theme from Adwaita to Adwaita-dark but it does not work. Every time we attempt to select non default values, things go back to default immediately.
We used gnome terminal and
a)We tried changing color theme of gnome-terminal and ,
b) tried to create a profile (please refer to the attached image)
that too did not work

Now when i attempt to run these gnome applications via command line, i see following error / warning message on terminal -

[user1@server1]~> gnome-terminal
# unable to open file '/home/user1/.cache/dconf-service/keyfile/user': Failed to map /home/user1/.cache/dconf-service/keyfile/user' /home/user1/.cache/dconf-service/keyfile/user': mmap() failed: Invalid argument; expect degraded performance

this message at application launch never used to appear before.
i manually created the /home/user1/.cache/dconf-service/keyfile directory (via mkdir -p) manually but this too does not help.

Please advice.

You are using a ridiculously outdated version of GNOME. I strongly recommend you ask your question on a CentOS support forum.