Unable to add spell checking dictionaries to Evolution

Just switched to pop os from arch based distributions and I’m having trouble adding spell checking dictionaries to evolution.

I have, as I have done in the past, installed the desired aspell-fr dictionary which appears to be installed without issue however, even after a reboot I can only see various options of English to choose from in Evolution.

I have tried on both laptop and desktop with same configuration and I have the same behaviour on both. I have tried re-reading the manual and googling but no obvious solutions.

Pop!_OS 22.04 LTS
Evolution = 3.46.3 (by Flathub.org)
aspell = 0.60.8-4build1
aspell-fr = 0.50-3-8.1

Many thanks in advance for any help or ideas you may have.

Hi,
it’s the problem, that it’s a Flatpak version. The Flatpak does not
read things from the host system, thus when you installed the
dictionary, it was not (and will not be) known to the Flatpak.
I think there is some trick to do it, by enabling/installing the
language support in the Flatpak (possibly for the org.gnome.Platform),
but I do not recall what precisely it was, I’m sorry.
Bye,
Milan

Thanks. Yes, you’re correct. It seems Flatpaks can’t access the dictionaries as described in the manual and you either need to install evolution via .deb or perhaps try this trick:

I reinstalled the .deb so can’t vouch for the above solution.
Thanks again.