Typing doesnt register with On Screen Keyboard when using Flatpaks

Since Fedora 36/GNOME 43, every time I try to use my touchscreen (tested on multiple devices now), I have the same problem.

Whenever I use flatpaks, tapping on a text entry field doesn’t open the on screen keyboard, and then even when I manually open them, characters aren’t entered into the selected field. The new word suggestion feature seems to pick up what I type, and backspace etc register, but not characters.

I’ve made sure all the apps are indeed opening in Wayland mode but beyond that I have no idea. The system interfaces and non-flatpaks are (generally) OK (although somewhat unstable and do develop randoms bugs at times but thats another issue)

I’ve been putting up with this for years but as more and more apps shift to predominantly Flatpak this is becoming really problematic for users with disabilities like myself who are basically dependant on touchscreens to use a computer at all, so I finally decided to take the time to type this up (which is hard!).

I’d really appreciate it if this could be fixed. Thanks

Video of the issue: Screencast from 2023-12-16 20-01-30

If the issue only appears in Chrome-based apps (as shown in the video), this might be because Chrome does not support the required text input protocol for Wayland yet: 1039161 - chromium - An open-source project to help move the web forward. - Monorail

This is not just confined to Chrome, i am running an Intel Bay Trail tablet (Linx 10), with Archlinux and Gnome installed from the Arch repos.

linux 6.7.1.arch1-1
gnome-desktop 1:44.0-1
gnome-shell 1:45.3-1

Arch/Gnome are fully up to date. Wayland is not in use, the tablet works best with Xorg, as selected in the Arch/Grub boot options.
Initially neither Joplin or Stellarium flatpacks appear to allow keyboard operation.

However, what is not happening in my case is that the automatic trigger for OSK to appear isn’t working.

If I tap into a text box and then swipe up from the bottom of the screen, the keyboard appears and is useable (unlike the OP).
It appears that the on-screen keyboard has to be invoked manually if an app installed under Flatpak is being used.
I have checked this out with Firefox, Joplin and Stellarium.
Neither Firefox or Joplin require any other touch functionality other than scrolling pages and both work fine.

However with Stellarium, which has significant touch screen functionality, on swipe up, there is a brief flash of the keyboard, but it doesn’t remain visible over the app.
No access to typed commands is therefore possible.
Stellarium has such things as two finger scanning across the sky, single tap on the screen to select an object and pop up information about it, and taps in certain areas of the screen to call up menus.
Once that swipe up has been made, functionality of the tap of the bottom & side boxes to access the commands is disabled.
As I have the Linx 10 tablet, there is a single “super key” pad below the screen, and I can shrink the workspaces, which (sometimes) allows the OSK to reappear. Once I minimise the OSK, and select the Stellarium app, the Stellarium touch control functionality reappears.

In trying to determine how consistent this functionality is, the tablet has partly frozen, any tap anywhere on the screen causes the keyboard space bar to flash as if it was being pressed.