Trouble installing Nautilus nightly with flatpak

[Please read my follow up about finding the gitlab repo also]


Someone interested in hacking nautilus here. I reached following the README on, and then executed the instructions exactly (two points under “Setting up GNOME nightlies” – setting up flatpak and adding the gnome nightlies remote source). But when I run flatpak remote-ls --app gnome-nightly, the output is empty. I tried both flatpak install gnome-nightly org.gnome.Nautilus.Devel and flatpak install gnome-nightly org.gnome.Nautilus and they were not found. Could somebody tell me what did I do wrong?

Hint: flatpak remote-ls |grep 'gnome-nightly' lists eight packages only, all low-level (not apps). seems the rew repo, right? I landed on the github page because of DDG. I understand a lot has changed in the instructions. Let me go through them. But why is the old repo still allowed to present itself with outdated info? Not a word about the new place. It is from the official github account of GNOME, isn’t it? Can I help?

Hello @nandedamana, welcome! Glad to have you interested in hacking on nautilus .

I suggest you follow the Newcomers Guide for how to setup the development environment the easy way.

That’s weird. That exact command works here. It lists all nightly apps.

Maybe you already had another remote with that name? What’s the output of flatpak remotes --show-details --show-disabled --verbose | grep 'gnome-nightly'?

There is another way to install the nightly development version. Maybe this works for you:
flatpak install --from

If the installation succeeds, the Nightly version can now be launched from Activities, or with this command: flatpak run org.gnome.NautilusDevel.

The GitHub page is just a mirror. It has the exact same content as the original repository at So, the instructions have not changed.

It really is unfortunate that both DuckDuckGo and Google shows the GitHub mirror instead of the original source.

It’s the official GNOME GitHub Mirror account, yes.

There is a link right there in the nautilus GitHub page that points to the original repository: githubnautilusheaderlink

But it’s probably too easy to miss.

Hi @antoniof, thanks for the detailed reply.

Maybe. I think I had terminated an add-repo command midway, but I had run the command to remove it before adding it again.

F: Opening system flatpak installation at path /var/lib/flatpak
F: Opening user flatpak installation at path /home/nandakumar/.local/share/flatpak
gnome-nightly	GNOME Nightly Builds Repository	-	1	system
error: No such ref 'app/org.gnome.NautilusDevel/i386/master' in remote gnome-nightly

(NOTE: I’m not being su)

Oh, they’re the same and I got confused because on github, I followed the link under “Supported version” and on, I followed the link under “Hacking on Nautilus”. My mistake.

Ah, there is the problem: there are no Nightly builds for i386 architecture. Only x86-64

But if you follow the Newcomers guide, you can build your own i386-based flatpak using GNOME Builder with a single click.

@antoniof Thanks. I tried the GNOME Builder method. It looks
friendly, but failed to install the runtime with insufficient
error messages. No console logs either. Let me try a manual build.

How do you know it failed to install runtime?

I knew it failed to install the runtime because it showed
something like “failed to install the runtime” without giving any
additional information. I tried Builder on my amd64 machine, it
doesn’t show any such error, but it shows another message “There
is a problem with the current build configuration”. Again, no
additional info, no noticeable errors in the console. I quickly
went through the Preferences and the log, didn’t notice anything
special. Let me check thoroughly. I’m writing this before my usual
fix-things-myself timeout, so there is a chance I figure it out
myself :slight_smile:

Ah, seems like I missed this in the console (maybe this is the
same thing I saw while using the other machine):
09:10:01.0243 gbp-flatpak-runtime-provider[ 6203]:
WARNING: Failed to install runtime: Child process killed by signal

BTW, this I didn’t report, because I thought it’s non-fatal:
09:23:28.0194 GVFS[ 6600]:
WARNING: can’t init metadata tree
/home/nandakumar/.local/share/gvfs-metadata/home: open: Permission

More info:

  1. amd64 machine: I had installed gnome-builder via apt, because I

had forgot about flatpak.
2. amd64 machine:
/home/nandakumar/.local/share/gvfs-metadata/home has the
permission -rw------- 1 root root, which I’m not going to change
before trying other things.
3. i686 machine: flatpak run org.gnome.Builder launches Builder,
lets me choose the downloaded nautilus repo, asks me if it’s okay
to install the i686 gnome Sdk, and when I click on “install” the
name of the Sdk starts scrolling on the top bar, and on hover, it
shows “Failed to install runtime”. No errors (not even warnings or
messages) on the console.

Got it build finally! I’m sad to report it like this, without any
insight on what went wrong and how it got fixed. The process
failed at different stages with little information on what went
wrong. One thing I’m certain is that my disk being full was a
factor sometimes.

Dowmloading/installing a runtime take a lot of disk space, so a full disk is a likely cause.

If Builder had provided a reason for runtime installation failure, it would have saved you a lot of time. Can you file an issue about this?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.