Tracker-miner-fs-3 not respecting .trackerignore and .nomedia


Although I have created .nomedia and .trackerignore under the directory ~/Documents/Archive, tracker-miner-fs-3 seems to completely ignored those two tracker-ignore files and consistently want to search and index the directory, I have SELinux enabled and I didn’t grant it such permission (because I don’t want to) so it just keeps trying and fail and return, is tracker no longer respecting trackerignore now?

System: Arch Linux
GNOME Version: 44.5

Sure I can just put a dontaudit rule on it but it seems like tracker is bugged on the directory and simply won’t continue to index others until it could index a directory that it can’t reaches


also

I don’t know SELinux at all.
But.
If SELinux is preventing tracker.miner to access the directory Archive, won’t tracker-miner find itself unable to see the “Archive/.nomedia” file, making its presence irrelevant?

1 Like

There’s your issue.

Note that the warnings you get come from GLib itself, if tracker-miner-fs-3 does not stop processing the folder it is because it doesn’t ever get an error propagated, and likewise if GLib does not stop and propagate an error, it is most likely because the kernel it not raising an error but giving it incomplete data instead. This is just one of the many possible outcomes if you mess with software at the system call level. Very few software projects, if any, will consider this a supported situation.

Tracker-miners 3.6.x available with GNOME 45 might help you, since it changed so the files declared at the ignored-directories-with-content setting are stat()-ed directly, instead of found through opendir()/readdir(). Or it might not, depending on the selinux rules.

Or you could grant the permission, and let tracker-miner-fs-3/glib find the .nomedia/.trackerignore files so they can be honored.

That absolutely makes sense, thanks