Tracker is driving me nuts

I’m getting seriously annoyed with Tracker, it uses all my resources and crashes my Fedora desktop. What happened to freedom when using FOSS, I want the freedom to permanently not use Tracker, how do I do it?

Hello Glyn,
If you want to continue to use GNOME but disable background indexing, the simplest way is to edit the search configuration so that no folders are indexed.

See the FAQ entry at FAQ - Tracker. You can either go by the settings “Search” panel (docs here) or the gsettingsCLI as documented in the FAQ entry.

I understand its frustrating when software doesn’t work especially when its stuck in a busy loop somehow, but remember GNOME is developed largely by volunteers & a constructive attitude is essential to getting the most out of it !

If you have an up to date version of Tracker (3.3.x is latest i think) then i’d be interested in seeing why the indexer consumes a load of resources on your system. There’s a guide here that lists useful info you could provide: FAQ - Tracker



Hello, please also note that the “freedom” in FOSS has always referred specifically to editing and redistributing the source code. It is not related to whether certain packages have dependencies on other packages or how a certain package is configured.

I’d expect a deleted post to be deleted, not have (post deleted by author). Anyway.

I disabled tracker by, I think, running this

systemctl --user mask tracker-store.service tracker-miner-fs.service tracker-miner-rss.service tracker-extract.service tracker-miner-apps.service tracker-writeback.service

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.