Thumbnail avi files

I don’t have thumbnail in Nautilus for avi videos (and only avi) anymore (i’m not sure it’s since this update or the former one).

It’s ok with dolphin.
Any idea?

Does playing those files in Totem work?

Yes, they work.
It’s just since the last update (i forgot to say i’m using manjaro kde), that there is a problem with thumbnail.
If i change the extension (mp4 for example), the thumbnail reappear.

What is the content type of the file (when the extension is avi) according to gio info -a standard::content-type the-file.avi? Does changing the extension change that? Are there any files in /usr/share/thumbnailers/ that claim to support the content type?

[marc@marc-pc ~]$ gio info -a standard::content-type a.avi

(gio info:60284): GLib-GIO-CRITICAL **: 12:35:23.599: GFileInfo created without standard::name

(gio info:60284): GLib-GIO-CRITICAL **: 12:35:23.599: file …/glib/gio/gfileinfo.c: line 1699 (g_file_info_get_name): should not be reached
uri : file:///home/marc/a.avi
chemin local : /home/marc/a.avi
montage unix : /dev/sdd2 / ext4 rw,noatime
attributs :
standard::content-type: video/vnd.avi
[marc@marc-pc ~]$

after renaming:
[marc@marc-pc ~]$ gio info -a standard::content-type a.mp4

(gio info:60366): GLib-GIO-CRITICAL **: 12:36:19.661: GFileInfo created without standard::name

(gio info:60366): GLib-GIO-CRITICAL **: 12:36:19.661: file …/glib/gio/gfileinfo.c: line 1699 (g_file_info_get_name): should not be reached
uri : file:///home/marc/a.mp4
chemin local : /home/marc/a.mp4
montage unix : /dev/sdd2 / ext4 rw,noatime
attributs :
standard::content-type: video/mp4
[marc@marc-pc ~]$

In /usr/share/thumbnailers/, i have that:

Does ffmpegthumbnailer.thumbnailer list video/vnd.avi in its MimeType when you open it in a text editor?

I have this

[Thumbnailer Entry]
Exec=ffmpegthumbnailer -i %i -o %o -s %s -f

You can try adding adding video/vnd.avi there and then restart Nautilus (make sure to either kill the process or wait long enough after closing the last window for it to actually exit).

A recent update of shared-mime-info changed the default mime type of AVI files from video/x-msvideo (which was already included) to video/vnd.avi: Prefer video/vnd.avi over video/x-msvideo (02741a47) · Commits · xdg / shared-mime-info · GitLab

1 Like

I’ve added video/vnd.avi and restart nautilus but no changes yet.
I wait a little and i’ll check it.
Thanks for your help. :sunglasses:

I checked and no thumbnail despite the change of the ffmpegthumbnailer.thumbnailer:

[Thumbnailer Entry]
Exec=ffmpegthumbnailer -i %i -o %o -s %s -f

Then probably further changes to the thumbnailer to adjust to the new mime type might be necessary.

You can try downgrading the shared-mime-info to 2.2, i.e. before the AVI mime type change. If that helps, that would confirm that the mime type change is indeed the cause of this issue. Then you could file a bug report against the thumbnailer here: GitHub - dirkvdb/ffmpegthumbnailer: Lightweight video thumbnailer that can be used by file managers to create thumbnails for video files

Also make sure to delete ~/.cache/thumbnails/fail to ensure that the previous failed attempts of generating a thumbnail are not preventing new ones.

I saw this:

Installing packages from the ALA is inherently dangerous as sometimes Manjaro needs custom versions of certain packages. Doing this can result in a broken system. As a result, downgrading from the ALA is disabled by default on the stable branch. If needed, you can enable it by setting the environment variable

I hesitate doing this.
I tried after downloading the 2.2 version sudo pacman -U shared-mime-info-2.2.tar.gz but it came with error (corrupt package).

I don’t think I can help with that since I don’t use Arch or Manjaro myself. That’s more a question for some Arch/Manjaro support forum.

Yes indeed.
Big thanks for your help. :wink:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.