Taskbar Issue: Cannot open file explorer from taskbar "Places" menu

Dear all,
I’m having issue where I can’t open the file explorer using the “Places” menu on the taskbar. I can click on the menu and the submenu is opened, but when I choose to open Computer, Home, or other choice, it does nothing. I can open the file explorer normally via “Home” shortcut on the desktop. The GNOME is running version 3.20.2 on SUSE 12 SP4, using RDP to XRDP.

Please let me know if you have any suggestion where to check, or this problem already posted somewhere else.

Thank you very much

Heh, that’s a blast from the past

Have you checked the logs? I imagine you’ll have some JS stack traces or other indication

Of course with what appears to be a fairly custom setup of that age you unlikely to get far here I’m afraid

I hope I didn’t misread the version. I tried to cat the gnome-version.xml and the content is:

platform: 3
minor: 20
micro: 2
distributor: SUSE

I think it would be better if I update the GNOME version (to solve the issue). Do you have any suggestion on link/website on how is the best practice to do GNOME update? I have no experience in handling GNOME before, so any advice is welcomed.

Thank you

It’s also quite far from upstream GNOME, considering that we have neither the taskbar nor the menu.

My guess is on modified window-list, app-menu and places-menu extensions, but it could also be Flashback .

You should report a bug to SUSE or upgrade to a newer operating system. Trying to upgrade GNOME to a version different than the one provided by the OS is going to be a disaster.

I think this is it, they just modify it to use the bottom of the screen instead of the top of the screen.

You are probably right.

So to sum it up: A heavily modified GNOME version that hasn’t been support upstream for over 5 years. It’s probably best to ask for support downstream.

Dear all,
Sorry for late update.

I have tried to create a test VM using similar OS and the bottom taskbar works without any issue. Since the production server (the one that’s having the issue) is owned by my client, I only suggest them to reboot the server. It was 5 days ago, and I haven’t heard any more complaints from them. I assume that fixed the issue.

Thank you, all

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.