Star doesn't work on files on partition

I keep my files on a partition.

user-dirs.dirs is edited to point Documents, Pictures etc to folders on this partition.

XDG_DOCUMENTS_DIR="/mnt/data/Documents"
XDG_PICTURES_DIR="/mnt/data/Pictures"
XDG_VIDEOS_DIR="/mnt/data/Videos"
XDG_MUSIC_DIR="/mnt/data/Music"

Star does not work for any files on the partition.

Can this be fixed?

perhaps something is wrong with my mount options

osuid,nodev,nofail,x-gvfs-show,x-gvfs-name=DATA,x-gvfs-icon=DATA,x-gvfs-symbolic-icon=DATA

This partition doesn’t show up in the left panel in Nautilus either.

Starring is only possible for directories in your home: https://gitlab.gnome.org/GNOME/nautilus/-/blob/6713fe13f3680bda5969e63598a082d68c3eea35/src/nautilus-tag-manager.c#L712-L721

oh cool, thank you.

will it work if I mount the whole drive as home in fstab?

Well, you don’t need to mount the whole drive as home. You can do it if you want but there is also another solution. I do not know if it will solve the problem of not being able to star files but here it is;

You can bind mount specific directories to your home. For example, following line, if put in /etc/fstab anywhere after the line for mounting /mnt/data, will mount the /mnt/data/Documents directory as /home/username/Documents

/mnt/data/Documents /home/username/Documents auto bind 0 0

cheers,

the bind thingie does activate the “Star” in the context menu, but I seem to have broken the whole Star system by disabling Tracker.
Which is weird because the star system works in my Clear Linux install which has Tracker disabled OTB.

in any case I now get two /Documents, the XDG one and a mounted directory, which is not ideal, however I didn’t know how to mount a directory like that before so learning BIND is pretty useful.

regards.

You can manually edit $XDG_CONFIG_HOME/user-dirs.dirs file and change its values back to directories in your $HOME and they will become the same.

The restriction to %HOME is meant to be temporary. But with so many things going on in the Files development, I haven’t found the time to finish that.

cheers,

good to know it’s not a bug . I’m just using a folder with symlinks in it instead for now, old school windows 3.1 style.

will the star system work without Tracker because I turned that off ( I just run ripgrep and fsearch, because I run audio stuff and the tracker chomps CPU ). Starring works on clear linux which has Tracker turned off, though I’ve not done extensive testing. Seems a bit complicated compared to say the Bookmarks.

You’re probably confusing tracker (which this application depends on) with the filesystem miner for tracker (which is probably what you’ve disabled).

ah, right, the name Tracker Miner makes a bit more sense now. disabled Tracker Miner, didn’t know Tracker was a seperate thing.

so I’ve moved everything to /home but the star doesn’t work but I think it’s because of another bug which seems to have been fixed for an upcoming release.

https://gitlab.gnome.org/GNOME/nautilus/-/issues/2278

thanks for the detail