SSH Agent and GNOME Keyring

Hello guys

I need an help to understand a weird problem, at least for me. Basically i’m unable to ssh to a remote linux and the problems it seems it is the SSH Agent in GNOME Keyring.

More or less the problems started since i have used to work remotely to a linux using xrdp protocol.

There is a way to completely fix/reset the Gnome Keyring SSH Agent?

I read this post

One of the option is to run the following command :slight_smile:

./configure --disable-ssh-agent

But from which folder?

It could fix the problem?


Wherever you cloned gnome-keyrind to, that’s a build option

Perhaps, but we don’t know what problem you are seeing!

Basically when i run ssh client within a terminal in a GNOME Session the connection attempt remains hanging without anything happening.

So how do you know it’s gnome-keyring at fault? "ssh is hanging" doesn’t really tell us much…

Have you checked things like the journal? Can you connect to $HOST from other machines?

1 Like

So my bad description of the problems but it was a collegue of mine who told the problelm coulb be the Gnome Keyring SSH Agent, as you see i’m noot so good in linux

As i told you when i try to ssh too another linux the connection is hanging, but if i switch to the terminal with CTRL-ALT-F3 it worked fine.

If from another PC i connect via ssh to this one, who have problem, then from this to destination PC i need to connect to, it worked perfectly.

Basically only under the gnome session the connection hangs, my collegue did some tricks to make it works, i remember:

  1. he checked for the PID with echo $SSH_AGENT_PID returing an not existing process ID

  2. he run few commands including ssh-agent to and ssh-add creating and registering a new agent. I don’t remember exactly the complete set of command he did, but he did that one for each opened terminal and this has to be done also for the new ones i need to open.

A reboot of the computer fix the problem but we are talking about a processing workstation and we we would like to avoid it

Perhaps your colleague could comment here?

I will try to contact him…but is hard i don’t know where is now :-).

Try this way when the problem happens:

gnome-keyring-daemon --replace --components=pkcs11,secrets,ssh
loginctl lock-session

Thanks!!! If happend again i wil try if it will fix the problem.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.