Some emails load really slow ~15 seconds to display

I read about 50 emails per day and 4 or 5 of them are always really slow to display. When It is unread and I select the email or open it in a new window, it remains blank for 15 seconds more or less when all other emails show their content seemingly instantaneously. I believe it happens all the time and isn’t something to do with the internet. It is predictable.

If I choose CTRL-u then the email source code displays immediately, no delay.

Because I send out newsletters myself, I’m now paranoid that it’s something to do with the email, which would seriously disrupt my outreach campaign - because I know that I often just delete the email rather than wait. I can jump to the next email and then come back to the problem email and I think in all cases it then displays properly - I will check that fact though, I’m not 100% sure on its consistency.

Is it definitely something in email, like the HTML or the internet connectivity for retrieving the email’s content, or is it something to do with Evolution?

If you want to see the email content, just say.

The Climate Nexus newsletter is a persistent offender. If you want to see the problem in action, sign up for it here:

Some extra info: today I sat there waiting for it to load, but got impatient. When I came back to it, it was no longer open in a separate window, just in the main window - but it was there. However I wanted to read it properly in its own window and double-clicked on the email. This launched its own window, but instead of loading instantly as I thought it would, it made me wait again, surely a sign that something in the email is causing Evolution problems, rather than any connectivity issue.

what is your Evolution version, please? It can be seen (and copied
from) for example in Help->About.

There can be multiple reasons why the view is delayed, depending on
your settings. Most often a lookup in the address book can sometimes
block for several seconds due to other pending requests. You can open
Edit->Preferences->Mail Preferences->HTML Messages and see what you’ve
set for the Remote Content Loading. Similarly the Sender Photograph
section of the Headers tab. Nonetheless, if I’m not mistaken, these
settings do not cause blank preview panel.

You mentioned you can move away from the message and back and it’ll
show the message immediately. I guess from that that the Evolution
itself is not stuck, it’s only the preview panel doing something odd.

You also mentioned that the message source can show quickly, which
means it’s not about the message size (large messages take longer to be

I think an ideal way to debug this in more detail is to install
debuginfo packages for the evolution-data-server, evolution, glib2 and
gtk3 and then catch a backtrace of the evolution process in this
state. You can get the backtrace with a command like this:

gdb --batch --ex “t a a bt” --pid=pidof evolution &>bt.txt

Please check the bt.txt for any private information, like passwords,
email addresses, server addresses,… I usually search for “pass” at
least (quotes for clarity only), before sharing it anywhere.

It’s possible a WebKitWebProcess (or one of them) is doing something
during that delay (it is shown in the system monitor, maybe a higher
CPU usage, but not necessarily). In such case a backtrace of that
process would hopefully help to diagnose this.

A similar WebKitGTK bug:
though there is a longer delay, thus maybe it is not related. I do not


3.48.1 (by

Can you tell me what the debuginfo packages are called? I’m using linux mint and for Evolution, flatpak. It doesn’t seem to know of any debuginfo packages.

You’re right that Evolution doesn’t freeze. It just shows a blank screen in the message display. I can close the display or move on to another msg without issue.

it’s kinda harder to debug anything with Flatpak:

Let’s try a simple thing first: you do not have the latest version, the offers 3.48.3 at the moment. Could you run from a terminal:

flatpak update

to get the latest versions not only of the Evolution, but also of the
dependencies, please? To ensure you run the latest bits, make sure you
also run:

flatpak kill org.gnome.Evolution

after the update, to stop the background processes Evolution lefts

I upgraded and the problem has disappeared! Not sure I should feel so pleased - problems that disappear are problems that can randomly re-appear. Anyway, with a bit of luck it won’t!

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.