[solved info] in the docs, the latest version is not always at the top or bottom.
Im trying out gtk-rs for the first time.
Trying out the example “basics”.
it wont build because the version of glib-2.0 is less than required.
"pkg-config" "--libs" "--cflags" "glib-2.0" "glib-2.0 >= 2.48" did not exit successfully: exit status: 1
error: could not find system library ‘glib-2.0’ required by the ‘glib-sys’ crate
— stderr Requested ‘glib-2.0 >= 2.48’ but version of GLib is 2.9.6”
error says glib version is less than the glib-2.0 required.
why does the request associate GLib with glib-2.0?
where does the request constraint come from? glib-sys?
are the constraints set by pkg-config flags? i havent modified the default flags, dont know how to.
have the latest glib (aka GLib) latest is 2.9.6 according to download.gnome.org/sources/glib.
installed the package libgtk-3-dev (libgtk-4-dev doesnt exist yet - edit: for MY distro (kubuntu)).
how to resolve this issue?