[SOLVED] GNOME Boxes - lost password recovery

I am asking the GNOME forum to see if anyone else here uses GNOME Boxes and has expereience with this same issue - how to recover a password with a VM from GNOME Boxes.

I tried to boot with a recovery CD, but could not find how to reboot with USB in GNOME Boxes. Do you know how to recover a password using GNOME Boxes, like how to boot from ISO/ rescue USB?

Alternatively, do you have advice on how to recover/ change the password with a linux application (gui or terminal)?

Thank you .

Attempts to change the .qcow image file:

Attempts to boot from ISO rescue USB:

[SOLUTION] Get out of GNOME Boxes and use virt-manager instead.

Thanks to this advice from a reddit user:

“It might be easier to just move your VMs from the Boxes location to where virt-manager does - /var/lib/libvirt/images. After that you just have to re-create the VMs in virt-manager, specifying the existing qcow2 file for storage rather than creating new.”

PROBLEM: In GNOME Boxes interface there is no way to change a lost password from rescue disc because the boot menu is not accessible.

SOLUTION: Move existing VM to libvirt, where you can access boot menu.

  1. Moved the GNOME Boxes VM image from here: ~/. local/share/gnome-boxes/
  2. Copied it to the libvirt location here: /var/lib/libvirt/images
  3. In virt-manager I created new VM importing existing data.
  4. From Boot Options, enable boot menu. Reboot from rescue usb.

If you add a bootable media in the Preferences dialog, Boxes should show the bootmenu.

Also, If the VM was created with express-install, you should find the password in the keyring.

P.S.: Boxes and virt-manager use the same stack which is developed by the same people. I’m happy when people solve their problems either with Boxes or virt-manager. We all win! :slight_smile:


Thank you for your response. I appreciate the info.

I just retried with Fedora ISO and the boot menu came up, so maybe it was a problem with me using the chntpw repair ISO rather than an OS.
I was never able to get the boot menu to show with bootable USB, which was the solution when I used virt-manager. I used a live OS on a USB and used chntpw repair software from there.

That is great to know that I could find the password in the keyring. Very cool.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.