Shotwell nightly flatpak is slow

This does’t seem to work Apps/Nightly - GNOME Wiki!

I have tried to use the nightly repository but all i get is errors like this
“mint@mint:~$ flatpak remote-add --if-not-exists gnome-nightly https://nightly.gnome.org/gnome-nightly.flatpakrepo
bash: flatpak remote-add --if-not-exists gnome-nightly https://nightly.gnome.org/gnome-nightly.flatpakrepo:
No such file or directory.
What am I missing or doing wrong

It looks to be a problem with that page. There are non-breaking space characters between the arguments in that command, instead of regular space characters. I think if you copy the command from that page it will not work. Try running the command copied from here:

flatpak remote-add --if-not-exists gnome-nightly https://nightly.gnome.org/gnome-nightly.flatpakrepo

I got it working
After looking at the link in LibreOffice I did see those special space characters and changed them.
Then I ran flatpak run org.gnome.Shotwell//master
Now it opens up but it is also very slow. It hesitate about 10 sec, when ever you try anything.
Can’t seem to find anything in the system logs that indicates a problem. Except for this line
in the terminal when starting
(shotwell:2): GLib-GIO-WARNING **: 02:12:49.383: Can’t find module ‘dconf’ specified in GSETTINGS_BACKEND

The data base only has 181 photo and 4 movies

I’ve corrected the page. It should be good to copy commands from the page now.

As for the Shotwell nightly flatpak slowness issue you’re having, sorry I don’t know how to help on that.

1 Like

All the link now have the proper characters.
Thank you.

There are certain reports that gphoto2 does some weird things on some machines inside a flatpak even without any devices connected. Can you try one of the work-arounds mentioned in either Unresponsive, freezing and crashing all the time after update. · Issue #39 · flathub/org.gnome.Shotwell · GitHub or Shotwell loading screen stuck at 99% (#5002) · Issues · GNOME / shotwell · GitLab ?

Ok so using one of the suggestions from as in

Unresponsive, freezing and crashing all the time after update

I ran

flatpak run --nodevice=all --devel --command=sh org.gnome.Shotwell

Did get a few errors

(gdb) r
Starting program: /app/bin/shotwell 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7ffff2d42640 (LWP 17)]
[New Thread 0x7ffff2541640 (LWP 18)]
[New Thread 0x7ffff1d40640 (LWP 19)]
Gtk-Message: 15:12:54.607: Failed to load module "xapp-gtk3-module"
** Message: 15:12:54.622: main.vala:429: Starting session with system profile

(shotwell:14): GLib-GIO-WARNING **: 15:12:55.891: Can't find module 'dconf' specified in GSETTINGS_BACKEND
[New Thread 0x7fffde292640 (LWP 20)]
[New Thread 0x7fffdda91640 (LWP 21)]
[New Thread 0x7fffdd290640 (LWP 22)]
[New Thread 0x7fffdca8f640 (LWP 23)]
[New Thread 0x7fffcffff640 (LWP 24)]
[New Thread 0x7fffcf7fe640 (LWP 25)]
[New Thread 0x7fffceffd640 (LWP 26)]
[New Thread 0x7fffce7fc640 (LWP 27)]
[Detaching after fork from child process 28]
[Detaching after fork from child process 32]

But the delay is now gone.

So according to this its some kind of USB issue on Oct 20 222
msmeissn** commented
libusb called by libgphoto2 hangs when opening /dev/bus/usb/xxx/yyy device. If it is stuck in open() directly, it might indicate a kernel issue or a locking issue.

I have no idea how to go forward now

When importing photo I do get this error. It can still import from my usb drives HMMMM, do get this error
GVFS-WARNING **: 15:25:08.581: The peer-to-peer connection failed: Error when getting information for file “/run/user/1000/gvfsd”: No such file or directory. Falling back to the session bus. Your application is probably missing --filesystem=xdg-run/gvfsd privileges.