Seahorse opens but no GUI appears

New Linux user here. I have Fedora 39 running and I installed Seahorse v43.0-4, however when I try to launch the application on my desktop, the icon shows in my GNOME tray, but the gui never renders.

Things I have tried:

  • Uninstalled, rebooted, and reinstalled seahorse using terminal
  • Uninstalled, rebooted, and reinstalled using GNOME app store (both the .rpm and flatpack versions)
  • Uninstalled, deleted my keychain, rebooted, created a new keychain, and installed seahorse

On every scenario, I open seahorse (Passwords and Keys) and the app shows on my app tray as an open application, however no GUI opens even if I leave it running for 15 minutes, and the app won’t close unless I use something like btop++ to kill the process.

I have searched online and could not find someone else having the same issue as this that was resolved so I wanted to post the question here and see if someone may know how to fix this.

I am a new Linux user coming from Windows-land so I don’t know how to properly debug Linux applications.

Can you run it from a terminal please? Maybe there is some bug and there will be relevant output displayed in the terminal?

Hi, thanks for the advice. I did call it from the terminal with seahorse but the same behavior happened, but in the terminal there is no output, it just stays blinking until I Ctrl+C out of it.


EDIT: I tried again but this time I used sudo and it opened just fine with elevated rights, but if I try without, or just clicking the icon the same problem happens.

Another update, today I ran sudo seahorse again, but now it doesn’t respond and crashes immediately, as well as throw the following errors.

(seahorse:40239): dconf-WARNING **: 12:13:49.802: failed to commit changes to dconf: Could not connect: No such file or directory

(seahorse:40239): seahorse-WARNING **: 12:13:49.803: gkr-backend.vala:94: couldn't connect to secret service: Could not connect: No such file or directory

Sorry, but once you run a GUI app as root, all bets are off. Not only is it not expected to work, but it’s also quite common that you will not be able to use the app as a non-root user anymore after doing so. My standard recommendation in these scenarios, if you’re not able to debug the problem yourself, is to reinstall your OS with a fresh home directory.

Never, ever do that again. Sorry you had to learn the hard way. :frowning:

That’s unfortunate, I would have loved a warning from the OS if it was this damaging. With that said, this was already broken with no errors or way to fix it, so I guess I’ll go back to Windows and maybe try Linux some other time. Kinda wanted a more secure OS, but I keep having these issues that keep breaking my experience that alone are tolerable, but together just take me away from what I want to use it for and force me to constantly tinker with it. I love Linux, but it feels like it’s still not 100% tinker free to get it working, but I’m glad it’s almost there. Maybe my next laptop will be a framework laptop with Linux out of the box.

I’d like this too, but my attempts thus far have all failed. Sorry. Ideally GTK would just abort immediately to prevent you from shooting yourself in the foot, but this is controversial.

Anyway to explain the problem: something important in your home directory is probably now owned by root rather than by you. You can probably no longer read or write it. That’s the most likely reason that seahorse will not start. This is just a guess; I don’t know for sure. Anyway, if you can figure out what files have messed up ownership, then you can maybe try to fix the permissions manually. This is not really something that users are expected to be able to do on their own, though. :frowning: The safest approach is to start over with a new home directory.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.