Rygel not seeing any .m4v files

I can’t get Rygel to see/stream any .m4v files.

How to remedy?

  • Which distribution?
  • Which GStreamer plugin packages do you have installed?
  • Do you see them when using GUPnP AV Control Point (from GUPnP Tools)?


I am on Ubuntu 22.04.1

I do not see .m4v files via the GUPnP AV Control Point application (but do see .mp4).

I have not installed any GStreamer plugin packages. Maybe I need to install a plugin somehow/somewhere?


The file extension should not make any difference. Can you post the output of
gst-discoverer-1.0 -v on an m4v and a working mp4 file?

gst-discoverer-1.0 is part of gstreamer1.0-plugins-base-apps package

Reading about this, it looks like I can just change the extension from .m4v to .mp4 and Rygel would then see it.

Still, would be good if Rygel could natively “see” .m4v files.

Looks like this was once up for consideration:

  • Add m4v, m4a and png to list of file extensions to entertain.

That changelog entry is from 0.7.7 which was released 12 years ago and was changed somewhen later to not lnonger rely on file extensions.

If renaming from m4v to mp4 fixes things, your shared-mime-info is broken

That must be it! I just made a copy of one of my .m4v files and put an extension of .mp4 on it. I CAN see it over DLNA.

Now if I could just figure out how to fix my broken “shared-mime-info”…

please run “gio info” on the file with both extensions and check the difference

And check that the package “shared-mime-info” is actually installed

please run “gio info” on the file with both extensions and check the difference

Weird. Both files – .mp4 and .m4v – indicate:

standard::content-type: video/mp4
standard::fast-content-type: video/mp4

That… Does not make any sense.

Can you check if the m4v file is perhaps marked as non-indexable my downloading https://gitlab.gnome.org/GNOME/rygel/-/blob/master/examples/mx-info and running mx-info --show-ignorelist foo or poking at the SQLite datbase?

I could not get that to work.

Is there some way to let Rygel know that it’s OK to stream files ending in “.m4v”? Seems like the actual file inside the .m4v is streamable, nothing wrong with it.

There is nothing in there that discrimiates according to file ending. I do not understand why rygel does not accept that file, if the output of gio info is identical.

Please run G_MESSAGES_DEBUG=all rygel -g 5

and then copy a m4v file that rygel has never seen into the videos folder. There should be log output telling you why it thinks it is or is not taking that file into consideration

Thanks! For my .m4v files I get:

…is not eligible due, it is ignored…

Question: If you take an .mp4 file and change its extension to .m4v, are you able to stream it via Rygel?

Yes. I am happily sharing mp4 and m4v files. Even the same file with different extensions.

This message is a) missing a word and b) means that the file was ignored because it was marked as unparseable before. Try

echo "delete from ignorelist;" | sqlite3 ~/.cache/rygel/media-export.db

All of the sudden, my .m4v files are appearing!

Did wiping out the DB file do the trick???

echo "delete from ignorelist;" | sqlite3 ~/.cache/rygel/media-export.db

MUCH appreciated,


That is just wiping all files that rygel has marked as “cannot read properly”. Most likely you downloaded that file into the shared folder? While Rygel does its best to wait until download is done, it will sometimes not recognize it properly and try to read metadata from a half-available file, and flag it as broken

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.