Rygel, firewall, ports

On Ubuntu Jammy. I am trying to configure my GUFW firewall so the ports Rygel needs are open. I see that UDP 1900 is required. I also set the following in my /etc/rygel.conf file:

The port to run HTTP server on. 0 means dynamic.


I then opened TCP 65530 in GUFW.

But still no joy – I’m still being blocked.

Which ports do I need to open? Alternatively, how can I force Rygel to use certain ports so that I then know which ones to open?

Much appreciated,


That is the setting to tell Rygel which port to use.

You need to allow 1900 UDP (there is no way around that) and the configured port in UDP and TCP. That should work, or it least it used to work.

Also make sure that there is no rygel.conf in the user’s .config overriding that setting.

I do believe that worked!

I round a rygel.conf file in my local .config directory. I deleted it. I restarted Rygel (by disabling it in Ubuntu Settings, then reenabling it), and looks like things are working.

It looks like this process placed a copy of /etc/rygel.conf my local .config directory. This version, though has Port 65530 in it. So all is well!

Many thanks,


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.