Run project from Builder : running but not displayed


I have developed a small flatpak application in Vala with Builder tool and I have following issue.

If I build the app, build the flatpak and install it on my computer and then run it (with flatpak run command or from Gnome Shell apps list) then it runs very fine : the main app window is opening and showing.
But if I run it from Builder, it starts (I see it in my app log and in the list of processes) but the main app window doesn’t display.
I use flatpak version of Builder 44.2 on my Fedora 38 with Gnome Shell 44.1 on Wayland.

When I run from Builder, I get this log :
note : I use french, I have translated below the french into english, thus it might be not exactly the message gotten with an english configuration

The application has started at 10:29:07
(process:2): GLib-GIO-DEBUG: 10:29:07.736: Using cross-namespace EXTERNAL authentication (this will deadlock if server is GDBus < 2.73.3)
(process:2): GVFS-DEBUG: 10:29:07.737: org.gtk.vfs.MountTracker.listMountableInfo call failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: org.freedesktop.DBus.Error.ServiceUnknown (g-dbus-error-quark, 2)

(process:2): GLib-GIO-DEBUG: 10:29:07.737: _g_io_module_get_default: Found default implementation local (GLocalVfs) for ?gio-vfs?
(process:2): GLib-GIO-DEBUG: 10:29:07.737: _g_io_module_get_default: Found default implementation keyfile (GKeyfileSettingsBackend) for ?gsettings-backend?

When I run the app fwith flatpak run command, I get no message (and trhe app opens fine).

I’ve spent time trying to understand and correct the root cause but no success. Maybe somebody here will find it, thank you in advance :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.