Right super key does not show the activities overview, but left super key does

Distribution: Fedora 35 Workstation
GNOME version: 41.1

I can press the left Super key on my keyboard to display the Activities Overview. Other keyboard shortcuts involving the Super key work with either one, including Super+S, which also displays the Activities Overview. However, the right Super key alone does not seem to do anything. I attempted to change the shortcut from Super+S to just Super in Settings > Keyboard > System, but nothing seemed to happen when I did that; the “Set Shortcut” window remained looking like the screenshot attached.

setShortcut

Is this intentional? I’m confused.

That’s because super is special, in that it uses a modifier as a regular key, while also making sure that the key can still be used in regular keybindings (normal key + optional modifiers). That special handling is enough of a pain in the arse even for a single key, so it was never extended to more than one.

(Which key is used is controlled by the overlay-key setting in org.gnome.mutter)

That’s interesting. I didn’t know about overlay-key. It looks like this was discussed in Issue #1277. While I’m currently a novice at programming, I’d be interested in seeing the handling code you mentioned there so that I can try to learn about this sort of thing. Is it somewhere in clutter?

The most relevant bits are in process_special_modifier_key().

1 Like