Right click menu in directory - "open in terminal" - only opens GNOME default terminal

This is one of those quality-of-life issues, that I’m bamboozled doesn’t have an easier way to configure already.

I know very few Linux users who are using the default GNOME (I think it’s Nautilus) terminal. We’re all installing Warp, or Kitty, or Terminator, or something.

But when you’re in a directory, and right click - “open in terminal” - it always opens the pre-installed terminal. Even if you set the default terminal to a different terminal emulator, the right click - “open in terminal” - doesn’t open what you’ve set as the new default terminal emulator.

So, I ended up using this repo: GitHub - Stunkymonkey/nautilus-open-any-terminal , and it worked, but it gave me TWO ENTRIES in the right click menu for - “open in warp”. My OCD kicked in, and because I only use progressive webapps, I just reinstalled Fedora (it’s a 15 min process for me).

But now that I’ve reinstalled, nautilus-open-any-terminal isn’t working. I have no clue why. It’s above my paygrade.

But it begs the question: Why can’t I just set a system wide default terminal emulator - that opens when I right click and select “open in terminal” - or otherwise edit the right-click menu, so that I can add it myself?

You KNOW that we’re all using a variety of terminals. Right click - “open in terminal” - should ALREADY open our terminal of choice. Hell, add into “default apps” as a dropdown choice.

I’ve wished for this for a while. Having it in the default apps and having a keyboard shortcut like we have for Email and Web Browser makes a lot of sense to me. I have to set up a custom keyboard shortcut for it every time I install Fedora.

I think Calculator might have the same issue - it’s not in Default Apps but it is in keyboard shortcuts. Possibly hard-coded there?

Because it’s… complicated.

I’m not joking. I originally thought this should be easy. Until I found out it’s not. It’s one of those things that should be simple and obvious but somehow, in more than 20 years, hasn’t been solved.

Good news is there are some efforts on this matter, with at least two possible solutions emerging.

So, hopefully we may see the case closed in the near future.

(Source: I am a maintainer of the Files app and I too wish people didn’t have to install extensions to open folders in their terminal of choice.)

1 Like

I brought up this “default apps” issue a few days ago for the default camera app for mobile devices / desktop, and they let me know that there is only a place for “default apps” if they are related to a MIME type or URL.

But, applications such as GNOME Builder do have hardcoded “default” apps, and so does Nautilus, where they will open GNOME apps (builder opens Epiphany if you click on a link on the terminal, Nautilus “Open with Terminal” opens GNOME Terminal, etc.)

That’s not what happens in my experience. It opens the default web browser, as set in Settings→Default Applications.

But otherwise you are spot on: the non-obvious difference between the concept of a “default terminal” and the other default apps is that it’s not about setting the default for a type of file or for a type of URL.

There is no generic way to “open in terminal” that all terminal apps support. Therefore, picking a default terminal app is useless at the moment.

The nautilus-open-any-terminal extension hardcodes individual invocation command lines for a set of terminal apps it supports. That’s not a sustainable solution. But it’s the only possible workaround at this time.