[Rhythmbox] iPod not recognized (certainly KDE/GNOME related)

Hello everyone,

I recently tried KDE/Plasma and have an issue with Rhythmbox and the iPod Video 5th gen. The iPod is properly recognized in Rhyhtmbox on other distros and other DEs, like XFCE and so forth.
In KDE the iPod is not recognized within Rhythmbox.
After manually mounting it with Dolphin it still can not be recognized.
I just tried in a standard MX Linux XFCE Desktop and it works without problems.
This seems to be clearly related to how KDE or rhythmbox is handling iPods and similar devices.
The iPod itself of course is recognized by the KDE system and can be mounted and I have read/write permissions, all good on the OS side. Path is /media/user/iPod.
On the same system the iPod is properly recognized by gtkpod and I can sync playlists and so on.

starting rhythmbox with the debug flag I get one interesting output:

(17:39:05) <rhythmbox> [uevent_cb] ../shell/rb-removable-media-manager.c:525: add event for /sys/devices/pci0000:00/0000:00:14.0/usb2/2-1 (bd89)
(17:39:05) <rhythmbox> [create_source_device_cb] ../plugins/mtpdevice/rb-mtp-plugin.c:204: matching device 5ac:1209 against libmtp device list
(17:39:05) <rhythmbox> [create_source_device_cb] ../plugins/mtpdevice/rb-mtp-plugin.c:232: device didn't match anything
(17:39:05) <rhythmbox> [uevent_cb] ../shell/rb-removable-media-manager.c:525: add event for /sys/devices/pci0000:00/0000:00:14.0/usb2/2-1/2-1:1.0 (0)
(17:39:05) <rhythmbox> [create_source_device_cb] ../plugins/mtpdevice/rb-mtp-plugin.c:200: couldn't get vendor or model ID for device (0:0)
(17:39:05) <rhythmbox> [uevent_cb] ../shell/rb-removable-media-manager.c:525: bind event for /sys/devices/pci0000:00/0000:00:14.0/usb2/2-1/2-1:1.0 (0)
(17:39:05) <rhythmbox> [uevent_cb] ../shell/rb-removable-media-manager.c:525: bind event for /sys/devices/pci0000:00/0000:00:14.0/usb2/2-1 (bd89)

The USB identifier for the iPod is:

Bus 002 Device 010: ID 05ac:1209 Apple, Inc. iPod Video

Please let me know if I can provide any other debugging information or logs.

I am copying a reply from another thread in here.
Can anyone comment on this?

Rhythmbox requiring GVFS/Gnome Virtual File System for iPhone/iPod detection. I don’t think it supports the KDE equivalent of GVFS (kio-fuse I think?), at least in regard to detecting iPod/iPhone.

Source: [Rhythmbox] iPod not recognized (certainly KDE related) - #9 by Nia - Help - KDE Discuss

Yes, that’s correct: Rhythmbox does not use KIO, so you’ll need the GVFS backend for Apple devices.

Alright, so an install of gvfs-backend and a reboot did the job. iPod is back online. :partying_face:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.