Restore backed up files to a different computer

I would like to recover files backed up on my external drive that are from my stolen laptop. When I run Backup from my desktop it only seems to find the desktop backups. Can you help? Thanks!

PS I tried using command line duplicity but I couldn’t get past errors about missing backup chains.

Hello! I’m sorry to hear about your stolen laptop! I hope I can help.

So into which folders on the external drive did you put your backups? Like <drive>/desktop-backup and <drive>/laptop-backup? If so, hopefully all you need to do is point at the right folder?

But since that feels like obvious advice, I wonder if you did something like make both backups to the same folder? Duplicity doesn’t love doing that (and it should have thrown up a warning at some point about it). But what that would mean is that each snapshot inside that directory was flip-flopping between your desktop and laptop files. They should all be there if so, you may just have to go back in time and find the right one.

Or is it some third situation?

Thanks for replying. The short answer to your question is that the backups are in different directories (with names similar to what you wrote :slight_smile: ) and the desktop and laptop show 2800 and 1300 files respectively. I may be close to a solution now, but I’d appreciate your comments.

The directory structure seems garbled. When I turn on the external drive it shows up in the left column of Files with the name “External Te”. Clicking on it (External Te) shows the 2 backup directories. Still in Files, when I then hit the BS key it takes me to a new directory: Computer/media/myname and this directory shows two directories: External Te and External Te1. Clicking on the External Te directory I get a permissions error and clicking on External Te1 brings me back to the original External Te list showing the 2 backup directories.

Finally, typing the following in a terminal window:
sudo duplicity list-current-files file:///media/myname/“External Te”/mylaptop
I get the following for the last line of output:
duplicity.dup_collections.CollectionsError: No signature chains found

However if I change the line to read External Te1 (not Te) I get what looks like a list of all the files. So maybe now it’s just a matter of tracking down the duplicity command to recover the files I want using this path with the Te1? (Any hints what that command might be? :slight_smile: ) And any ideas why I have a Te and a Te1, especially since Te shows as the name in the Files window?

Finally, I assume there’s no hope of doing what I want to do with the GUI? When I fire up the Backups program (does that just call dejadup?) there seems no mention of being able to access different backups.

Again, thanks for your original reply and any other advice you might have for me. Finally, yes, getting a laptop stolen is miserable for so many different reasons. :frowning:

Hello! The duplicity command line is a bit of a beast.

I think you could use something like:

sudo duplicity restore "file:///media/myname/External Te/mylaptop" ~/restore-folder --file-to-restore home/myusername/fileiwant.txt

Check man duplicity for more.

As for other questions:

  • Yes “Backups” is just the generic application name for Deja Dup
  • It should work in the GUI - that’s still a bug. When you set the storage location for your backup, does the dropdown have multiple drive entries that look the same? Try each of them in turn, if so. Might be a similar problem to the Te and Te1 issue where there’s two of the same thing visible, but only one works.

Hi! The replacement laptop is due in a couple of weeks but I now have every confidence I can get what I need off the backup using the information you’ve given me. I really appreciate your help.

Side comment: I can’t believe how lucky I was to accidentally hit the BS key in Files or I would never have found the mysterious Te1 directory containing the backed up files.

1 Like

Don’t hesitate to report back if there are problems! It’s stressful to not have access to your backups

Success. Thank you very much. Two final comments: (1) On my new machine the behavior of Te and Te1 were switched. Go figure. (2) To repeat something everyone has heard too many times - I wish I had backed up more recently.

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.