Reinstalling GNOME Desktop

I have a Skylake CentOS 7.7 laptop that I was updating a few days ago. One of the patches was a microcode_ctl patch, which does not play nicely with Skylake. The update died with a kernel panic. Needless to say, I could only boot into the recovery mode. None of the other kernel images worked.

I finally recovered from all of the duplicate packages using some instructions from Red Hat. Now, though, my GNOME desktop doesn’t load. It starts to, but never gets to the login prompt. I have to press Ctrl+Alt+F2 and log in through a command-line.

I tried running a yum groupremove “GNOME Desktop”, and it removed three packages. Reinstalling only installed those same four packages. They are bpftool, google-noto-emoji-fonts, and spice-streaming-agent.

How do I get my desktop working again? I’ve been wondering is this might be a good time to try Stream 8, but I’d rather get the desktop working.

1 Like

The journal looked at journalctl -xe errors?

You should ask on a CentOS user support forum.