[Question] About using GNOME software to manage Flatpak only without touch .rpm packages

Hi dears.

I like to use GNOME software to manage only Flatpak packages installation/removal/update without touching .rpm packages because I’m already using DNFdragora for .rpm

The aim: use DNFdragora to manage .rpm packages & repositories & GNOME software to manage Flatpak packages only without touching .rpm packages, to avoid duplication in cache & because most of GNOME bugs related to PackageKit.

I’m on Fedora Linux 32 X64 Cinnamon edition, & doing this is nearly straight forward because DNF show “PackageKit” as a weak dependency & it already has an option to install package without it’s weak dependencies. So, I performed the following:

sudo dnf install gnome-software --setopt=install_weak_deps=False

It worked very well & GNOME software only show me Flatpak applications in market. Also, it become so light in it’s working !

However, I have 2 issues:

  1. GNOME software showing me an error message saying what mean: “a wrong is happened … can not reach Dbus.freedesktop.sdk … name is unavialable …”. It is something approximate … It appearing specially when navigate to “update” tab. I think (or sure) that it is related to absent of “PackageKit” … My question is how to disable this error message ?
  2. does GNOME software in this case (without PackageKit) able to perform automatic update for Flatpak packages that are already installed on my system ?
  3. does GNOME software in this case (without PackageKit) still able to give me notification about existance of new updates (for my already installed Flatpak package off-course not .rpm) ?
  1. GNOME software in this case (without PackageKit) still show me in “installed” tab not only my already installed Flatpak packages, but my already installed .rpm packages & beside each “launch” & “remove”. So, does it be possible to remove such .rpm package by clicking on “remove” ? It should be not because “PackageKit” already not existing, isn’t it the case? If yes, then is there a way to make those already installed .rpm packages not appearing at all in “installed” tab

I will be very thankful if someone solve me these issues !

Best.

I found the solution: we need for BOTH methods to achieve satisfaction as following:

a. install GNOME software without it’s weak dependencies:

sudo dnf install gnome-software --setopt=install_weak_deps=False

b. remove GNOME software’ s PackageKit’s plugins:

cd /lib64/gs-plugins-13

sudo rm -i libgs_plugin_packagekit*

The problems that I encountered after installation of GNOME software without it’s weak dependencies, including “PackageKit”, represented by repeated error messages, were due to existence of complete set of GNOME software plugins that used to interact with “PackageKit” & these plugins will continue their works even if “PackageKit” not installed ! They do not recognize whether “PackageKit” is installed or not.

These plugins are located in ~/lib64/gs-plugins-13 in Fedora 32. You should remove them all in block, to get rid from error messages …

The issue that I’m afraid from it is that I think the removal of these plugins should be repeated manually every time GNOME software updated to new version … Even the name of their folder “gs-plugins-13” may be changed on update package or upgrading of system …

The already installed .rpm packages still visible on “Installed” tab, & you still see “remove” option, but certainly will not work (I did not tried, but certainly will not work), & the source of such .rpm package appearing as “Unknown” - see attached screenshot:

Otherwise, now every other thing is okay. Now I have GUI to manage flatpaks (GNOME software) & DNFdragora to manage .rpm packages, each independent from other without any interference between them.