Currently, among the other options,
GTK_JUSTIFY_RIGHT. Would it not be better to rename them to
GTK_JUSTIFY_END? I am implementing a widget in which the
GtkTextDirection) can be changed, and in the case of
GTK_TEXT_DIR_RTL together with
GTK_JUSTIFY_START things would be aligned to the right, whereas making things aligned to the right using
GTK_JUSTIFY_LEFT would be very counterintuitive.