Prevent window from being auto-maximized on Wayland (Gnome Shell)

Mutter auto-maximizes windows that take >80% of monitor’s work area.

I want to prevent my application’s window from being auto-maximized (it is also undecorated, and window size is configured in application settings).

On X11 I can disable maximization using gdk_window_set_functions(). But it doesn’t work on Wayland.

Is there any way to disable maximization or prevent window auto-maximization on Wayland (in Gnome Shell)?


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.