PGP encryption when pub key identity is not recipient email address

I am experiencing issues when encrypting emails via PGP if the receiving email address differs from the identity associated with the public key. e.g. when I want to write user+identifier@email.provider

Is there something I can edit to achieve something like thunderbirds/enigmails recipient rules ? i.e. specify the encryption key for a certain email address.

See if I understand correctly.

nope, it is not about aliases and signing (which uses my private key) it is about encrypting.

I want to encrypt an email. I have the public PGP Key for the address user@mail.provider but I want to send the email to the email address user+identifier@mail.provider order something@mail.provider (doesn’t really matter)
This email should be then encrypted with the public key belonging to the identity user@mai.provider.

I do not see how this is possible.

So it sounds like user+identifier@mail.provider is an alias for user@mail.provider?

not in the terminology of evolution. aliases are other email identities for the email account I have credentials to.

I’m afraid having a per-alias option for Security is too complex, which means, in your use case, the only option is to use the old way of defining account aliases, which means to configure a send-only account,

this does not apply in my case since i do not want to send mails neither with user@mail.provider nor with user+identifier@mail.provider. I want to encrypt mails for them, and send it to them. A send-only account does not help here.

the issue is, that evolution selects the (public) encryption key according to the recipients email address. However, there are situations I have a public key for the recipient as a person, but not for the email address specified in the public key of the recipient. Or am I wrong? Is the solution obvious? Then I would be very happy for detailed explaination.

Ah right yes sorry duh (I even use them myself), this is about aliases for targets not sending

In Seahorse you could try adding a name to the pgp key (double click the key → Names and Signatures → Add Name). No idea if that’ll work but it’s worth a try I guess.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.