On-screen keyboard layout on Debian OS

Hi everyone,

I’m on Debian 11 Bullseye. I have an application which works only with touch screen. I added Korean(hangul) language to the system, sudo apt install ibus-hangul. I also set it to start in hangul mode, so the characters that I type in are Korean characters.

But the keyboard layout of the virtual keyboard is still in Australian English layout. When I click them, I saw Korean characters in entry.

What should I do to change the On-screen keyboard layout? I also attached a screenshot below. You can see, at the top, there are Korean characters.


I tried installing this language from the settings and the same occurred to me

But then I tweaked the language button on panel and activated the ‘Hangul mode’ and ‘Hanja lock’ and some simbols appeared. I don’t know if that’s what you’re looking for, since I don’t understand the Korean.
And you may also check the Setup option in this menu, if you haven’t already.
There’s also a option in the Setup, which indicates the shortcut Shift+Space to toggle ‘Hangul Mode’ and F9 to ‘Hanja Lock’

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.