No HEIC import & some Video thumbnails missing

Running a pretty vanilla install of Fedora 38 with Gnome 44.5.

I’ve installed the rpm for Shotwell, 0.32.2.

I’ve run into a few issues that, if I can figure out, would really make Shotwell a killer app for me.

  1. Not importing .heic files
    I recently installed libheif, which instantly created thumbnails in Files. However, Shotwell doesn’t seem to even be importing the .heic files. My understanding is the 0.32 release started supporting heic.

Any suggestions on what I can do to import heic into Shotwell?

  1. Some video thumbnails not loading in Shotwell
    The thumbnails load in Files, but not in Shotwell. I have not noticed a pattern on a specific file type. I’ve noticed it on .mov and .mts files. But some will have a thumbnail, and not strictly a size issue.

I recently tried installing ffmpegthumbnailer, but this did not have any impact on Shotwell. (I have not tried deleting any thumbnail cache. Some have reported this helps, but I’m not sure what files to delete.)

Any ideas what I can try to get video thumbnails loading in Shotwell?

  1. Faces detection support in Shotwell?
    I’ve read that Shotwell now supports some form of face detection. However, I do not see this option anywhere.

Any clues if this was perhaps left out of the Fedora rpm? Otherwise, what do I need to enable Face detection in Shotwell?

Thanks much for trying to help me getting Shotwell fully up and running!

1 Like
  1. HEIC import is broken on Fedora 38 due to missing support in exiv2. This might change for Fedora 39. That said, just importing the images with thumbnails should work, you will not get any meta-data, as long as you install the libheif-freeworld (from rpmfusion) and heif-pixbuf-loader packages

  2. Shotwell does its own video thumbnailing using GStreamer, so make sure you have all the plugins installed (good, bad, ugly, av)

  3. Previously face detection was off in Shotwell because the license of one dataset used for the detection isn’t very clear. The slightly worse detection algorithm that has clear licensing of the data files that was provided with 0.32 was probably not activated for historical reasons. I am afraid that there is either recompiling Shotwell yourself or switching to the flatpak from flathub, which has face detection and working HEIF support, but other issues.

1 Like

Just to clarify: Fedora’s libheif will not support HEIC anytime soon because unlicensed decoders are illegal. As mentioned by Jens, you need libheif-freeworld from RPM Fusion instead.

1 Like

Thank you jensgeorg and mcatanzaro, this is really helpful.

1 & 2 - I didn’t realize the gstreamer plugins were necessary for shotwell. After a bit of googling I ran:

$ sudo dnf install gstreamer1-plugins-{bad-*,good-*,base} gstreamer1-plugin-openh264 gstreamer1-libav --exclude=gstreamer1-plugins-bad-free-devel

also installed ugly.

HEIC files imported upon reopening Shotwell. :grinning:

Many video thumbnails are loading, but some have not. I have not been able to identify a pattern for which types are not loading. Does not seem to be anything specific such as too big, specific format etc.

I’m noticing it mainly for .mts, .mov pulled from iOS HEIC, and .mp4 from a DJI video.

Would love any ideas on how to get over this final hump to using Shotwell.

Is there a way to simply force loading thumbnails for specific files?

Thanks again.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.