Need help, any PNG larger than 26 MiB causes the png plugin to crash

Here’s a screenshot:
I am using arch linux on the lts kernel, with gimp 2.10.34. I mostly use gimp to edit PNG files from my scanner, but that has become a problem since something updated and now anything larger than 26MiB crashes the png plugin. I know it isn’t a ram problem, I can open and edit a 1GB .tif image with no problems. Unfortunately any solution I have been able to find for this kind of problem has been a recommendation to allocate more ram, but I have 32gb which should be way more than enough to load a png, especially on the smaller side. I have also seen this happening with other image viewers, making me think the broken png plugin could be gtk related. I’m at a loss for a solution, does anyone know what’s happening? Thanks

I routinely scan large PNG images (e.g. hundreds of megabytes on disk, multiple gigabytes in memory). I use xsane and save to a file rather than the gimp plug-in, which is limited to 8-bit colour depth.

Can you paste the full output of ImageMagick’s “identify” command on an image that crashes gimp for you? Is it possible the image has faulty metadata? Maybe also paste the output from exiftool?

Thanks for the reply!
here are the command outputs (different image, same result):

magick identify scan0027.png 
scan0027.png PNG 5452x4088 5452x4088+0+0 8-bit sRGB 27.4732MiB 0.000u 0:00.000
exiftool -k scan0027.png
ExifTool Version Number         : 12.60
File Name                       : scan0027.png
Directory                       : .
File Size                       : 29 MB
File Modification Date/Time     : 2023:03:04 01:14:29-07:00
File Access Date/Time           : 2023:06:19 22:23:55-06:00
File Inode Change Date/Time     : 2023:06:19 22:21:50-06:00
File Permissions                : -rwxrwxrwx
File Type                       : PNG
File Type Extension             : png
MIME Type                       : image/png
Image Width                     : 5452
Image Height                    : 4088
Bit Depth                       : 8
Color Type                      : RGB
Compression                     : Deflate/Inflate
Filter                          : Adaptive
Interlace                       : Noninterlaced
Pixels Per Unit X               : 47244
Pixels Per Unit Y               : 47244
Pixel Units                     : meters
Modify Date                     : 2023:03:04 08:14:15
Author                          : 
Description                     : 
Copyright                       : 
Creation Time                   : 
Software                        : 
Disclaimer                      : 
PNG Warning                     : 
Source                          : 
Comment                         : 
Title                           : 
Image Size                      : 5452x4088
Megapixels                      : 22.3

I can create (and reload) a 200MB PNG (10000x10000px filled with “Plasma”) with Gimp 2.10.34.

AFAIK Gimp calls libpng for most of the work, so it could be a problem with your version of libpng. In Gimp 2.10.34, the minimum level for libpng is 1.6.25. The version on my system is 1.6.37 (I run Kubuntu 22.04.02, by the way).

If you start Gimp in a terminal you may have additional information about the crash…

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.